summaryrefslogtreecommitdiff
path: root/net-misc/yt-dlp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-24 11:22:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-24 11:22:25 +0100
commit6a851e4f7c23c15c4b7853e6c34b0a0b9bc68482 (patch)
tree027421c2b8ddbc8c802c488ba086753da35fcfad /net-misc/yt-dlp
parentfcf991edcc1b310199e4e829a3706bc1c267d1db (diff)
gentoo auto-resync : 24:09:2023 - 11:22:25
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest2
-rw-r--r--net-misc/yt-dlp/yt-dlp-2023.09.24.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 75e79b0f4969..000cdcff1d50 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,4 +1,6 @@
DIST yt-dlp-2023.07.06.tar.gz 5362006 BLAKE2B a1675bf6fc41a4a4fb90401a50cc0dc7e84d4d751aed7ee9520d04fba8060f6c877a13d9a9e07ce8f36ffb2053f6048d54eaa5628d97c41457b36b965127d342 SHA512 f9f276ccd01293d27a749575653449d73e13896c175a51f3687b2f6d1c6b97154f6c9fb2868f0c37a6e94cb692e223c7c595e741c5b2db82d2b9e1d0b2f8958d
+DIST yt-dlp-2023.09.24.tar.gz 5494731 BLAKE2B 558fc80691951ba33e591a9bf1820e3da45f265f9392d28c6dcab1c2feb9bac84a0143d8034dde8c772f227eb9896c6406974440bd141ac88de0899438f229e0 SHA512 37f1c5c9af9f8cdd66a2fa09771f018042c3efac61a657ea1573a68a77dce2f76fbd8bb7a59ed72942093ddfd80d57573305ec8b60d00e6b0ba50276e3df2dfd
EBUILD yt-dlp-2023.07.06.ebuild 1904 BLAKE2B 2481fbe36a0eb0f85530410a012d1947611adbbd759214f7f416e538a3ee837f14560c07c878f25e885f49d2de7a898b0d931ecc578d0177b26218f2b3ee61c6 SHA512 ac8d5cbe2c61430dbab82fbb391a83d0f14d43a801e151c0dc907cce3adb6df4d322099b9f47b995168f8080dbbe4b9094082bee8ca26cff428a03dd7d2229c6
+EBUILD yt-dlp-2023.09.24.ebuild 1910 BLAKE2B cefcb58569941c2f57e7151238c4b61ebd2e7c2bae7cd3f92ba083e214b1f6958b6f68a0151d1b33d1c2d2658fde42601e9564eba6e6dd77e7137483757ec9a6 SHA512 8fd3373a005248c7d1058b513e8305cee4401396f506332803735ed6a39096ac7e4bb2656484d571ee49b83e89f2a50ebd7a2f58eefa6d34d0b8d58c11004f67
EBUILD yt-dlp-9999.ebuild 2084 BLAKE2B 67653d1662b620ca58857a5fc2353cf5187390cafedb13bf23f04e05a330e8ef9eeaf1e84655cdbffddbe5b227e523194e36a00706014271c145b5fcf8b1c5b6 SHA512 5f309555ac68f210f2a1b52f87f7055acd20d89e18747141e29f9a4770c4bce4b08ecc41e13a254f41dfb1bdf4c64ca10541617038f6cb80496d8b21ad34ca26
MISC metadata.xml 392 BLAKE2B d2aa6fc43f7f9038d320197a18107f15e56ed5e242e6c3cdc1b7111184580ab14fae8cbd16776794d207dd39ea0ca65975c08a54449f4cf90370ea95a66083d9 SHA512 867c61c1e41d7594decd5e10a2b45d934313cb751ba22356fc1ab61e0a40b2543847b195d20c7a39ba92370d8b3908e6f90d690915579b55808872efe8d3cebe
diff --git a/net-misc/yt-dlp/yt-dlp-2023.09.24.ebuild b/net-misc/yt-dlp/yt-dlp-2023.09.24.ebuild
new file mode 100644
index 000000000000..5f12f57f85ed
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2023.09.24.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri requirements.txt \
+ -e "s/^(pycryptodome)x/\1/" \
+ -e "/^(brotli.*|certifi|mutagen|websockets)/d" || die
+}
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}