summaryrefslogtreecommitdiff
path: root/net-misc/ytfzf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-16 11:57:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-16 11:57:19 +0000
commit61f62e5edc868fc4ae3b92af397397ee5056578a (patch)
tree81261ca75a34aa85973eeb3cd828878c4e72bcee /net-misc/ytfzf
parent433cb2e828d414c74b16d429f40d25e179b0a70f (diff)
gentoo auto-resync : 16:01:2023 - 11:57:19
Diffstat (limited to 'net-misc/ytfzf')
-rw-r--r--net-misc/ytfzf/Manifest2
-rw-r--r--net-misc/ytfzf/ytfzf-2.5.4.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index 3174941621d6..c10b95aa3ea7 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1,3 +1,5 @@
DIST ytfzf-2.5.3.tar.gz 3265442 BLAKE2B e920bf60a567741cc84739d20f282c27036eafaa823ea273439e49f9b855798a11f611ee8b4893490538d24c3039f2780451272f82ead73c45fb0f2124e05417 SHA512 fcc9e6064fe381972f30a94fd418ba9a497fed4be891f40b75e608a4c095f7b311000ae104d8e877b52622defa4ff57cb0ec1ace4d034ba08f0ff3985438d58d
+DIST ytfzf-2.5.4.tar.gz 3273455 BLAKE2B 9e4ba90cca7a17fc8c7283097db1925582b9dbb85b9b83db77f2e20a48db7566a8396114256bcb61bffb281ac0ce64f199702f495cd07f2e4e11d0c81605a973 SHA512 48ab12314a638d2682eb387c1d0bd2c8979762287194d897d801c1b845c28e3e6c2b383e1fede75e0b0649ab401855e6a9ee48a58cfc4e08b0f291da877ed150
EBUILD ytfzf-2.5.3.ebuild 1428 BLAKE2B e2eddcee03517c5a01ceac852c4e4945f3da15d3fcb96f9fa028dafd4a0d52884e5b19e1ed0660ad49d4155b4171b88f731e16599ef26ff1f4c582ed77bb7992 SHA512 07d64edc61bb5ecd11ea4f88622da466999f353fb0b25cd86a3c9cd386739ec61e9f641ad082cb8113f4fd555a8e7d00347516f5153925173027ca6821ccff3a
+EBUILD ytfzf-2.5.4.ebuild 1511 BLAKE2B 8a2c8ddbaf4762d38b14d5a2b2dc7e06746eaed5432ca725b6e935e30301c644402e7079dd816cc5bc1d8d23d836592c40583c6b98b7618b774f3fd4240e1b9a SHA512 a9b90c9be7305e8bbd24933d76b627b11619af72ac50104737f444ec0014ec11f191bc8e626ac56c742d8e9b501b8cfdb1572d7835cbceb08f84b98328c1941c
MISC metadata.xml 498 BLAKE2B 465ce6a83a75395c9021b7208a156bc91f55fe2522279a781509bc490e832611e89718317c88d4e2986f16f6ea1f8bc457d2f5978efa011e62c56cef756cf0ed SHA512 49f6d3c039246622d687f63b703390eef0d4fef51f485a091ccdb767da1b2cd8a380275cabe6117465add0e15acf6f6533033a5b17c751091abe462a43044884
diff --git a/net-misc/ytfzf/ytfzf-2.5.4.ebuild b/net-misc/ytfzf/ytfzf-2.5.4.ebuild
new file mode 100644
index 000000000000..17d70945b125
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.5.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+# this release seem to ahve several regressions, expecting another release soon
+#KEYWORDS="~amd64 ~x86"
+IUSE="X minimal"
+
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ app-alternatives/awk
+ !minimal? (
+ X? ( media-gfx/ueberzug )
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ )"
+
+src_prepare() {
+ default
+
+ sed -i "/^: ...YTFZF_SYSTEM_ADDON_DIR/s|/usr/local|${EPREFIX}/usr|" ytfzf || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" addons doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that ${PN} supports many methods to display menus/thumbnails."
+ elog "This ebuild primarily covers defaults and major features, additional"
+ elog "dependencies may be needed for others. Set USE=minimal if want full"
+ elog "control over optional dependencies (e.g. fzf is optional if use dmenu)."
+ fi
+}