summaryrefslogtreecommitdiff
path: root/net-misc/ytfzf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /net-misc/ytfzf
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'net-misc/ytfzf')
-rw-r--r--net-misc/ytfzf/Manifest3
-rw-r--r--net-misc/ytfzf/metadata.xml15
-rw-r--r--net-misc/ytfzf/ytfzf-1.2.0_p20211208.ebuild44
3 files changed, 62 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
new file mode 100644
index 000000000000..37024bdf8e39
--- /dev/null
+++ b/net-misc/ytfzf/Manifest
@@ -0,0 +1,3 @@
+DIST ytfzf-1.2.0_p20211208.tar.gz 3230303 BLAKE2B eb1cc05945bc91226d9a3f893edfcfcc5d8544ac2607d6bec7bfc5dd4a8f4b0c01e7387a73d82d148e908e727a1f2809765c9e21e13ca9e7de947c68c1a28f10 SHA512 f87dea2afb706ec9ea23fab3fa02833ddeff7261807f8e2e77471829fe05d293644c6b1d75660cbaae798cfdaede5553d1eabcf6b608a08a7a9d2de825ab92a2
+EBUILD ytfzf-1.2.0_p20211208.ebuild 1083 BLAKE2B 9b3075fd59ebea17f97c33072cb8b4200a60698af92eaa30877eb17fc43447caf4827123d157061237b42d65048ad8015e71594f342b0ec18f056d59078b17d1 SHA512 7e5dbe88fd2651dd127c0fa943e72a6c6ed0cb49f1e80b0ab3e9cc5bfcdcea24fba7ad1b93a1899ed8462badee6d0c1bbe6b4d7be0764e5318db953a855483db
+MISC metadata.xml 498 BLAKE2B 465ce6a83a75395c9021b7208a156bc91f55fe2522279a781509bc490e832611e89718317c88d4e2986f16f6ea1f8bc457d2f5978efa011e62c56cef756cf0ed SHA512 49f6d3c039246622d687f63b703390eef0d4fef51f485a091ccdb767da1b2cd8a380275cabe6117465add0e15acf6f6533033a5b17c751091abe462a43044884
diff --git a/net-misc/ytfzf/metadata.xml b/net-misc/ytfzf/metadata.xml
new file mode 100644
index 000000000000..b6a91b9d9370
--- /dev/null
+++ b/net-misc/ytfzf/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <use>
+ <flag name="minimal">Skip <pkg>app-shells/fzf</pkg> and <pkg>media-video/mpv</pkg> dependencies (requires custom settings)</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">pystardust/ytfzf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/ytfzf/ytfzf-1.2.0_p20211208.ebuild b/net-misc/ytfzf/ytfzf-1.2.0_p20211208.ebuild
new file mode 100644
index 000000000000..0ba10e67d3ae
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-1.2.0_p20211208.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+MY_COMMIT="dc7b0056e9b84cf786e6e4adda7f91564d1d012f"
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+# fzf/mpv "can" be optfeatures depending on configuration, but depend
+# on them so it works as expected out-of-the-box and allow to disable.
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ net-misc/yt-dlp
+ !minimal? (
+ app-shells/fzf
+ media-video/mpv[lua]
+ )"
+
+src_compile() { :; }
+
+src_install() {
+ dobin ytfzf
+
+ dodoc README.md docs/{USAGE.md,conf.sh}
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu x11-misc/rofi
+ optfeature "in-terminal thumbnails on X11" \
+ "media-gfx/ueberzug dev-python/pillow[jpeg]"
+ optfeature "desktop notifications" x11-libs/libnotify
+}