summaryrefslogtreecommitdiff
path: root/net-nds/ldapvi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-16 09:35:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-16 09:35:57 +0000
commitb982051e7c8e12c3810a0d21d30d687b406b3ae5 (patch)
tree1f40c63a302b92f633c075f289851ab62633babe /net-nds/ldapvi
parentb62381b18b4bf2e919cbfbae11ebcad391e38e77 (diff)
gentoo auto-resync : 16:12:2022 - 09:35:57
Diffstat (limited to 'net-nds/ldapvi')
-rw-r--r--net-nds/ldapvi/Manifest2
-rw-r--r--net-nds/ldapvi/files/ldapvi-1.7-fix-implicit-function-declarations.patch86
-rw-r--r--net-nds/ldapvi/ldapvi-1.7_p20101214-r4.ebuild57
3 files changed, 145 insertions, 0 deletions
diff --git a/net-nds/ldapvi/Manifest b/net-nds/ldapvi/Manifest
index d624fd4b08a1..2b902188ff66 100644
--- a/net-nds/ldapvi/Manifest
+++ b/net-nds/ldapvi/Manifest
@@ -1,3 +1,5 @@
+AUX ldapvi-1.7-fix-implicit-function-declarations.patch 2185 BLAKE2B 0cf16e855a221a78106a8c1e4d57b50fead25b1ea871798b1a445cc0f7af1073cf0fc7ce7dd4b1962d4e7c5da844fb1e97ad51508b292447f88338c87bf76856 SHA512 f8b9a139b371074a4677a78a024c1e5134c1110a0c7dbfe702da9efe6275ecdcca4c40f746ec99f157a2cb159bce447ef38d94e2391dc7cb40f844d14fa14539
DIST ldapvi-1.7_p20101214.tar.bz2 1490491 BLAKE2B 21bb7b6113e89ce848e7a8efcec063dbfe9c32331c1125456a96dc6edc4e09d17245307a041a7d7804fac20bcce5b38677d719fb53d993fb874134bbd4d4df19 SHA512 2d2a744a36364793f406f37ecf6e546914d697457dec37b81544f4979f4c692756b2a1c3ea6fcbaba5e3238b2bf758ab3e0bd9a9a0794c4da734d65286bd5925
EBUILD ldapvi-1.7_p20101214-r3.ebuild 1016 BLAKE2B a39e9e5336e7a3e2571c6ed8acadcfecdc503e717598571eafd4a1393a356bd47849688b525ab166d51fbd117351858849a8d119b939f124f44c9e1f317117db SHA512 f2460d8f72dc474489ce1c8a000fa182d6a0b3513f3bafbdefa3efd7e326309fede73e7a7fdaf777f3e43e02c29ff1a1fb048b0e83411012eac3bd5d30d400fe
+EBUILD ldapvi-1.7_p20101214-r4.ebuild 1105 BLAKE2B 857b2c99b5b2ca2a54697c21668675b6e69cd2436ec10321328a7cebf5b3641e30102ff37856aa44e04b8e944439745db42cfacff6b706b341e5f19d3181d775 SHA512 94472ef9221d87aa8096dfeb53436d7f422bc357fe0a2c9cb6022b559e01c7840a1dcbcfa8de5ecccf28647743f4ba7d66e50bdc01c49b8efb85021c9bb00c62
MISC metadata.xml 279 BLAKE2B ed38c142d61f6990bbe12ecd7766fc9e0f1a1577ecbf8eb856d9b235171dbc8ec9a8632c02cfddfe6c587ed3144a417161d00e7818400f56758d4b08289e51d1 SHA512 f20b66bb26c85e5b3c2ecc1a29c136979ee430b88858c79cc673583301f7d3df9aa41dd3c18f432a1580dd5549431e9e7b6e7359f24b6f56f8e20f9bd7f478fa
diff --git a/net-nds/ldapvi/files/ldapvi-1.7-fix-implicit-function-declarations.patch b/net-nds/ldapvi/files/ldapvi-1.7-fix-implicit-function-declarations.patch
new file mode 100644
index 000000000000..f78bc8c8c199
--- /dev/null
+++ b/net-nds/ldapvi/files/ldapvi-1.7-fix-implicit-function-declarations.patch
@@ -0,0 +1,86 @@
+Date: Sun, 11 Dec 2022 19:05:47 +0100
+Subject: [PATCH] fix implicit function declarations
+
+Clang16 will not allow implicit function declarations by default.
+This patch add the declarations to make this package build with
+Clang16 defaults.
+
+Also patches some -Wreturn-type while at it.
+
+Bug: https://bugs.gentoo.org/882229
+Bug: https://bugs.gentoo.org/740852
+Patch has been sent upstream via mail.
+
+Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
+--- a/common.h
++++ b/common.h
+@@ -370,3 +370,5 @@ void finish_sasl_redirection(tsasl_defaults *);
+ tsasl_defaults *sasl_defaults_new(bind_options *bind_options);
+ void sasl_defaults_free(tsasl_defaults *sd);
+ int ldapvi_sasl_interact(LDAP *ld, unsigned flags, void *defaults, void *p);
++
++void fdcp(int fdsrc, int fddst);
+--- a/diff.c
++++ b/diff.c
+@@ -18,6 +18,7 @@
+ #include "common.h"
+ #include "config.h"
+
++char ldap_bv2dn_x (struct berval *bv, LDAPDN *dn, unsigned flags);
+ typedef void (*note_function)(void *, void *, void *);
+
+ static void
+--- a/parse.c
++++ b/parse.c
+@@ -17,6 +17,7 @@
+ */
+ #define _XOPEN_SOURCE
+ #include <unistd.h>
++#include <crypt.h>
+ #include "common.h"
+
+ #define fast_g_string_append_c(gstring, c) \
+--- a/error.c
++++ b/error.c
+@@ -14,6 +14,9 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
++
++#define LDAP_DEPRECATED 1
++
+ #include <dirent.h>
+ #include <errno.h>
+ #include <fcntl.h>
+--- a/port.c
++++ b/port.c
+@@ -35,6 +35,7 @@
+ #if defined(HAVE_OPENSSL)
+ #include <openssl/sha.h>
+ #include <openssl/md5.h>
++#include <openssl/rand.h>
+ #elif defined(HAVE_GNUTLS)
+ #include <gnutls/gnutls.h>
+ #include <gnutls/openssl.h>
+--- a/ldapvi.c
++++ b/ldapvi.c
+@@ -1470,7 +1470,7 @@ copy_sasl_output(FILE *out, char *sasl)
+ int line = 0;
+ int c;
+
+- if (lstat(sasl, &st) == -1) return;
++ if (lstat(sasl, &st) == -1) return -1;
+ if ( !(in = fopen(sasl, "r"))) syserr();
+
+ if (st.st_size > 0) {
+--- a/misc.c
++++ b/misc.c
+@@ -585,7 +585,7 @@ dialog_rebuild(char *up, char *clreos,
+ putp(up);
+ }
+
+-static Keymap
++static void
+ set_meta_keymap(Keymap keymap, Keymap meta_keymap)
+ {
+ if (!meta_keymap)
diff --git a/net-nds/ldapvi/ldapvi-1.7_p20101214-r4.ebuild b/net-nds/ldapvi/ldapvi-1.7_p20101214-r4.ebuild
new file mode 100644
index 000000000000..cead88df63bf
--- /dev/null
+++ b/net-nds/ldapvi/ldapvi-1.7_p20101214-r4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Manage LDAP entries with a text editor"
+HOMEPAGE="http://www.lichteblau.com/ldapvi/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+S="${WORKDIR}"/${P}/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="gnutls sasl"
+
+RDEPEND="dev-libs/popt
+ dev-libs/glib:2
+ sys-libs/readline:=
+ sys-libs/ncurses:0=
+ virtual/libcrypt:=
+ gnutls? (
+ net-libs/gnutls
+ net-nds/openldap[gnutls]
+ )
+ !gnutls? (
+ dev-libs/openssl:0
+ net-nds/openldap[ssl]
+ )
+ sasl? ( dev-libs/cyrus-sasl:2[ssl] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.7-fix-implicit-function-declarations.patch" )
+
+src_prepare() {
+ default
+
+ # bug #459478
+ sed -i \
+ -e '/^AC_SEARCH_LIBS/s:curses ncurses:curses ncurses tinfo:' \
+ configure.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-libcrypto=$(usex gnutls gnutls openssl)
+}
+
+src_install() {
+ dobin ldapvi
+ doman ldapvi.1
+ dodoc NEWS manual/{bg.png,html.xsl,manual.{css,xml}}
+}