summaryrefslogtreecommitdiff
path: root/net-nntp/newspost/newspost-2.1.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-nntp/newspost/newspost-2.1.1-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-nntp/newspost/newspost-2.1.1-r3.ebuild')
-rw-r--r--net-nntp/newspost/newspost-2.1.1-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-nntp/newspost/newspost-2.1.1-r3.ebuild b/net-nntp/newspost/newspost-2.1.1-r3.ebuild
new file mode 100644
index 000000000000..2bead23b4f88
--- /dev/null
+++ b/net-nntp/newspost/newspost-2.1.1-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A usenet binary autoposter for unix"
+HOMEPAGE="http://newspost.unixcab.org/"
+SRC_URI="http://newspost.unixcab.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+src_prepare() {
+ # Should fix some problems with unexpected server replies, cf. bug 185468
+ epatch "${FILESDIR}"/${P}-nntp.patch
+ epatch "${FILESDIR}"/CAN-2005-0101.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+
+ sed -e "/-strip newspost/d" -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBS="${LDFLAGS}" main
+}
+
+src_install () {
+ dobin newspost
+ doman man/man1/newspost.1
+ dodoc CHANGES README
+}