summaryrefslogtreecommitdiff
path: root/net-nntp/suck/suck-4.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /net-nntp/suck/suck-4.3.4.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'net-nntp/suck/suck-4.3.4.ebuild')
-rw-r--r--net-nntp/suck/suck-4.3.4.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-nntp/suck/suck-4.3.4.ebuild b/net-nntp/suck/suck-4.3.4.ebuild
new file mode 100644
index 000000000000..ecb5006bebe9
--- /dev/null
+++ b/net-nntp/suck/suck-4.3.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Grab news from a remote NNTP server and feed them to another"
+HOMEPAGE="https://lazarus-pkgs.github.io/lazarus-pkgs/suck.html"
+SRC_URI="https://github.com/lazarus-pkgs/suck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="perl ssl libressl"
+
+RDEPEND="
+ sys-libs/gdbm:=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ sys-libs/db
+ perl? ( dev-lang/perl )
+"
+
+src_prepare() {
+ default
+
+ # Fix paths to the locations in Gentoo
+ sed -i \
+ -e 's:/usr/bin/rnews:/usr/$(get_libdir)/news/bin/rnews:' \
+ -e 's:/var/lib/news/history:/var/spool/news/db/history:' \
+ suck_config.h || die "path adaption sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ if use ssl; then
+ sed -i -e 's/^SSL_/#SSL_/' Makefile.in || die "ssl sed failed"
+ fi
+
+ if use perl; then
+ sed -i -e 's/^PERL_/#PERL_/' Makefile.in || die "perl sed failed"
+ fi
+
+ econf --without-inn-lib --without-inn-include
+}
+
+src_compile() {
+ emake phrases.h
+ emake all lpost
+}
+
+src_install() {
+ dobin lmove lpost rpost suck testhost
+ doman man/*
+ dodoc CHANGELOG CONTENTS README*
+ docinto java
+ dodoc java/*
+ docinto perl
+ dodoc perl/*
+ docinto sample
+ dodoc sample/*
+}