summaryrefslogtreecommitdiff
path: root/net-p2p/amule/amule-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
commit32b8124b0a5827960601f2183a970103b3d231b7 (patch)
treefebd1cb81d2417f5452d0e21f81d06663f12caa3 /net-p2p/amule/amule-9999.ebuild
parent89e7f1cd6dd17f245898939477ef38d45dd112b9 (diff)
gentoo auto-resync : 19:12:2023 - 07:53:49
Diffstat (limited to 'net-p2p/amule/amule-9999.ebuild')
-rw-r--r--net-p2p/amule/amule-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-p2p/amule/amule-9999.ebuild b/net-p2p/amule/amule-9999.ebuild
index 1dc6203a5561..c1743eff2384 100644
--- a/net-p2p/amule/amule-9999.ebuild
+++ b/net-p2p/amule/amule-9999.ebuild
@@ -52,6 +52,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-2.3.2-disable-version-check.patch"
"${FILESDIR}/${PN}-2.3.3-fix-exception.patch"
+ "${FILESDIR}/${PN}-2.3.3-backport-pr368.patch"
)
pkg_setup() {
@@ -70,6 +71,7 @@ src_prepare() {
}
src_configure() {
+ use debug || append-cppflags -DwxDEBUG_LEVEL=0
append-cxxflags -std=gnu++14
local myconf=(
@@ -105,6 +107,10 @@ src_configure() {
econf "${myconf[@]}"
}
+src_test() {
+ emake check
+}
+
src_install() {
default