summaryrefslogtreecommitdiff
path: root/net-p2p/bitcoin-cli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /net-p2p/bitcoin-cli
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'net-p2p/bitcoin-cli')
-rw-r--r--net-p2p/bitcoin-cli/Manifest3
-rw-r--r--net-p2p/bitcoin-cli/bitcoin-cli-0.21.0.ebuild102
2 files changed, 105 insertions, 0 deletions
diff --git a/net-p2p/bitcoin-cli/Manifest b/net-p2p/bitcoin-cli/Manifest
index 16512f544a48..46c523f01cf0 100644
--- a/net-p2p/bitcoin-cli/Manifest
+++ b/net-p2p/bitcoin-cli/Manifest
@@ -1,4 +1,7 @@
DIST bitcoin-0.20.1.knots20200815.patches.tar.xz 413244 BLAKE2B bc8fd6bfe0454439ae514086ea3e728df4f1ba069d33f79b047049a1a4d18543334217f25607b738f7f2d1245f64e5289aed00473c94edf5d660e0953e4d6b93 SHA512 98468f4f22d5b9d35c616796aa5a8fda20f775606f0cd4927b3b822dd5afd0fc208c23136306f79d01dbfd532b14a5905a8fb60a2d171d5022d2008772cf7b58
+DIST bitcoin-0.21.0.knots20210130.patches.tar.xz 505040 BLAKE2B c8999de4158b8781bba6ad014ae14859f1e0bab3080c59a18910cf7447eb56da4b17a0e1843fdd3669d22636df9e4ddcc4526e4293bfd86dc884983a29a5f76c SHA512 7ee27da3d26be0e93ecddff7bb21ef1746bcdb07f9a2b0ea48065367b4c44391e974e04a21e511c05fca8f55971ab8e3c3ac01a3775cc52a537d9e10966d9871
DIST bitcoin-v0.20.1.tar.gz 6986090 BLAKE2B ef0e6c424bcb7ffe9a2461e60499cebdfcd13faa794d534b4c508a61fa218dd58e64c9088584ea658736deeadc0306fbdf08daa3c395dac3d8f096a08ba42262 SHA512 73a103d4192eb12abed5aa84e9c7999d57e4da37f32e54107ab9f4297a29af64c0c56930674559073bed360f794d87ba5eb9e1ce4d1bd03402d56937490fa16e
+DIST bitcoin-v0.21.0.tar.gz 7533957 BLAKE2B 01247cbb9fca2381a8c08ab1c88c479c640963caef22e4207aab46b05813dbf2a5286ac9e98132fb34db0e9ac6c18c79e45a89de166f5c6d480d8ac6e14ecca2 SHA512 c58187996932b0151432a65885b7e8a7b216fb1ab0576fb7d4b5e9620d957594b05e181153e2e0e50bcd5ce764861ec11019ffbb1095d3e704f441e61ac6a04f
EBUILD bitcoin-cli-0.20.1.ebuild 2403 BLAKE2B 414b07e98b2852ead13310e929b7f844c1b2bf499a36acc34a02dc406f5dfb2b4bcd80a0932463873ca6666fc8d6715147c1446ad94dc8e2748be899bd44bf27 SHA512 93c2e949cc565e7f273a3e4a9e607eea4ec46d0ad1cd2be442ac7e4009bf7bd80f047a15df5fc78e7a69d904523a218ffe32cc7b21429ae15e879aa70389c676
+EBUILD bitcoin-cli-0.21.0.ebuild 2405 BLAKE2B a3c2083abd385e13307e3bf1c2d0996aa925e4ec22e9999769074ba4de111fddc82a991a1bced5664a0292cfef9ec7a4a7824e338f8b97c2b75ca5e967431ea1 SHA512 5932bbb9c7023d2410e1a45df3aa623578923ab8acdab6b000d7f22d01a362d5019f1da89ad5a2135c4429bed9750c03a4630fb05ed5acb052977ee0224cf0ab
MISC metadata.xml 763 BLAKE2B 3c5d0ae0cd584fab16d75fe32bc92173b70ce7721f8c3eb8346b79d4b8682a5ebee40e9fa37b182b5dd50d2dac4de7c4c3205bf9cf3a00128c621fb7fee34c25 SHA512 0bf4b0c264587054acab434ea97ccb7a80387b6d21deb836f2a87a5fbdeb7f0cda9f7423fc579401f2a89a6f4cb26be43b875e9d0e94a7b4289c5dbde63758a2
diff --git a/net-p2p/bitcoin-cli/bitcoin-cli-0.21.0.ebuild b/net-p2p/bitcoin-cli/bitcoin-cli-0.21.0.ebuild
new file mode 100644
index 000000000000..81b7d45f7b87
--- /dev/null
+++ b/net-p2p/bitcoin-cli/bitcoin-cli-0.21.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+BITCOINCORE_COMMITHASH="95ea54ba089610019a74c1176a2c7c0dba144b1c"
+KNOTS_PV="${PV}.knots20210130"
+KNOTS_P="bitcoin-${KNOTS_PV}"
+
+DESCRIPTION="Command-line JSON-RPC client specifically for interfacing with bitcoind"
+HOMEPAGE="https://bitcoincore.org/ https://bitcoinknots.org/"
+SRC_URI="
+ https://github.com/bitcoin/bitcoin/archive/${BITCOINCORE_COMMITHASH}.tar.gz -> bitcoin-v${PV}.tar.gz
+ https://bitcoinknots.org/files/0.21.x/${KNOTS_PV}/${KNOTS_P}.patches.txz -> ${KNOTS_P}.patches.tar.xz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="knots"
+
+DEPEND="
+ >=dev-libs/boost-1.58.0:=[threads(+)]
+ dev-libs/libevent:=
+ >=dev-libs/univalue-1.0.4:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=sys-devel/autoconf-2.69
+ >=sys-devel/automake-1.13
+"
+
+DOCS=(
+ doc/release-notes.md
+)
+
+S="${WORKDIR}/bitcoin-${BITCOINCORE_COMMITHASH}"
+
+pkg_pretend() {
+ if use knots; then
+ elog "You are building ${PN} from Bitcoin Knots."
+ elog "For more information, see:"
+ elog "https://bitcoinknots.org/files/0.21.x/${KNOTS_PV}/${KNOTS_P}.desc.html"
+ else
+ elog "You are building ${PN} from Bitcoin Core."
+ elog "For more information, see:"
+ elog "https://bitcoincore.org/en/2021/01/14/release-${PV}/"
+ fi
+}
+
+src_prepare() {
+ local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
+
+ eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
+
+ if use knots; then
+ eapply "${knots_patchdir}/${KNOTS_P}.f.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.branding.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.ts.patch"
+ fi
+
+ eapply_user
+
+ echo '#!/bin/true' >share/genbuild.sh || die
+ mkdir -p src/obj || die
+ echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
+
+ eautoreconf
+ rm -r src/leveldb src/secp256k1 || die
+}
+
+src_configure() {
+ local my_econf=(
+ --disable-asm
+ --without-qtdbus
+ --without-qrencode
+ --without-miniupnpc
+ --disable-tests
+ --disable-wallet
+ --disable-zmq
+ --enable-util-cli
+ --disable-util-tx
+ --disable-util-wallet
+ --disable-bench
+ --without-libs
+ --without-daemon
+ --without-gui
+ --disable-fuzz
+ --disable-ccache
+ --disable-static
+ --with-system-univalue
+ )
+ econf "${my_econf[@]}"
+}
+
+src_install() {
+ default
+
+ newbashcomp contrib/bitcoin-cli.bash-completion ${PN}
+}