summaryrefslogtreecommitdiff
path: root/net-p2p/cpuminer-opt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
commit2f51c9978dda4c6e8debca43e4235ecc86914032 (patch)
treebc41e1c4383040034174c327504f702c8517a123 /net-p2p/cpuminer-opt
parent51536d2fe4697ba9114d611178bb9e20d3d5b729 (diff)
gentoo resync : 25.12.2017
Diffstat (limited to 'net-p2p/cpuminer-opt')
-rw-r--r--net-p2p/cpuminer-opt/Manifest5
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.7.7.ebuild47
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild47
-rw-r--r--net-p2p/cpuminer-opt/files/cpuminer-opt.service27
-rw-r--r--net-p2p/cpuminer-opt/metadata.xml11
5 files changed, 137 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
new file mode 100644
index 000000000000..dc7c788053f4
--- /dev/null
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -0,0 +1,5 @@
+AUX cpuminer-opt.service 690 BLAKE2B f95dff31fb5ff12da8b8ae282bba4c0fd15b5c0aa7e0f2b87f94a901a8e15ea5c81e6704fe5e81681383a3d82c41516174c4cae3a6dc59c9d2af618197f32189 SHA512 d175754246d61d08d615af52c3499d67e4d8c6a5166f07ea4fd646f3000ca7afed99f9b436785c50141a86b5faf017be4b2d1d5d2f9e3921a6171e4223be9b4c
+DIST cpuminer-opt-3.7.7.tar.gz 1602520 BLAKE2B 059afdbd90ff062c698432d352fbb9f32807219a24659f5e27990a32b791d868147cf6fa027dff60d2e16d5f43b36b826dbabdc971e4dae4e1473aaf8795b222 SHA512 85989257ef8ee945000621598f6a9c4ed1b8099c57902d570db3038617b787254a925865567541d75e4433aaff564ffc82bd659f645ca812f809602bef8bc7c7
+EBUILD cpuminer-opt-3.7.7.ebuild 1075 BLAKE2B 10de22358a2bf8896da6db2151e8f5984d531fbaca07fe1032ee11785e3f19b612113ca0ae7324e1b1811e8ec465964eac3aa37e1b7892056a511bda75a2aaac SHA512 083f2279b51a96509cc585f234d49f3a15b6f441ac383708a94caeddc00b10485fcc5c3a09cd8b701813f7a0186639436bd6c49edefb4f03a1d86dee2a2b3863
+EBUILD cpuminer-opt-9999.ebuild 1060 BLAKE2B 63e3b702153f5961a892904b5146f8367d30a663efc028222738e745bf0e45c9016b5d645f41219fb3efcb485921c46ea9a8c1e97c454dfa796929f3bf19b3b1 SHA512 a4ccb1664da6b692b53b7a76c127e8f3bf3b6f8e0772b9c4ba1b430b7a18d9d374eec58a53f93fc23e78ffa4b36fbf5e8486cb1c46701e1538a054085cdcbe73
+MISC metadata.xml 333 BLAKE2B f7851fe0d55d729c75e3934fa32ab578c57d3dfc4a1634cc8dcca655f0d4ab1a6bb56d0b9c347dedb6cedf3d5a5a7a1bb9662856733970b1cc8db288c26be4a2 SHA512 770d39605bb1afa7d7643b4fc8f295e449f90175ae0d31c8a5023bfc9ba233c9e80ebf1dfbf81c4b86af8dc1d66bc336a4464748f162119b35fcb695cd54e656
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.7.7.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.7.7.ebuild
new file mode 100644
index 000000000000..3ff3d3b75188
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.7.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_avx2 cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ use cpu_flags_x86_avx2 && append-cflags "-DFOUR_WAY"
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
new file mode 100644
index 000000000000..9d637b9169d3
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_avx2 cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ use cpu_flags_x86_avx2 && append-cflags "-DFOUR_WAY"
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
diff --git a/net-p2p/cpuminer-opt/files/cpuminer-opt.service b/net-p2p/cpuminer-opt/files/cpuminer-opt.service
new file mode 100644
index 000000000000..90ee849c5bac
--- /dev/null
+++ b/net-p2p/cpuminer-opt/files/cpuminer-opt.service
@@ -0,0 +1,27 @@
+[Unit]
+Description=CPU mining daemon for cryptocurrencies
+After=network-online.target
+AssertFileNotEmpty=/etc/cpuminer-opt/cpuminer-conf.json
+
+[Service]
+ExecStart=/usr/bin/cpuminer --syslog --config=/etc/cpuminer-opt/cpuminer-conf.json
+DynamicUser=true
+CPUSchedulingPolicy=idle
+PrivateTmp=true
+ProtectHome=true
+ProtectSystem=strict
+NoNewPrivileges=true
+PrivateDevices=true
+CapabilityBoundingSet=
+MemoryDenyWriteExecute=true
+ProtectKernelModules=true
+ProtectKernelTunables=true
+ProtectControlGroups=true
+RestrictRealtime=true
+RestrictAddressFamilies=AF_INET AF_INET6 AF_UNIX
+RestrictNamespaces=true
+PrivateUsers=true
+ConfigurationDirectory=cpuminer-opt
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-p2p/cpuminer-opt/metadata.xml b/net-p2p/cpuminer-opt/metadata.xml
new file mode 100644
index 000000000000..b95044df0235
--- /dev/null
+++ b/net-p2p/cpuminer-opt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">JayDDee/cpuminer-opt</remote-id>
+ </upstream>
+</pkgmetadata>