summaryrefslogtreecommitdiff
path: root/net-p2p/go-ethereum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-p2p/go-ethereum
reinit the tree, so we can have metadata
Diffstat (limited to 'net-p2p/go-ethereum')
-rw-r--r--net-p2p/go-ethereum/Manifest4
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild32
-rw-r--r--net-p2p/go-ethereum/metadata.xml19
3 files changed, 55 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
new file mode 100644
index 000000000000..7a0c1a542f95
--- /dev/null
+++ b/net-p2p/go-ethereum/Manifest
@@ -0,0 +1,4 @@
+DIST go-ethereum-1.5.5.tar.gz 14957844 SHA256 364a55b381b5bbf60c09a0e2a9a624d9c08dacb6570725cc2801af7c35db7690 SHA512 4429d0aaceb0e6ffa92f85674ad50ddb092436b97fabb4ff09439c408a762155ae7077b0a69432cf4a2397aea2ff3c4d603713ea1cd304a831b8aa9c039314ea WHIRLPOOL 1df86ba09bece09d5956b4b90f09e2a7897307e37b68332a777714106391c8c6bc441020f2f82bc3345133efb46c2597824fe4bb637055f0d40a2a7d947c3177
+EBUILD go-ethereum-1.5.5.ebuild 646 SHA256 8bfbeb72437b160b9726a18dbfc18d87fb32a5a1b52c7f487d2ef2baaaee269c SHA512 25298e5b286b87a9a4a040127d33bbb6fccef76d30c9fd3f7fe380bfc560667f112eceda726e42491aa7d9a0210ce07fefd4efa79ab9e87afb78183c88cc9359 WHIRLPOOL ee51aa2bae32effc2d9f363cf394a6d47dc13429014b8b1c0e094bfbdb36d8461248ab9608de743a8abb3ee0cdaa80ccaffaafa1128bab04f0a73197f47d25ac
+MISC ChangeLog 2088 SHA256 5a977fb43ae291524248c592a5d6d6365a62bee8cbf79eb9e8f7f89b8b6aa6d6 SHA512 3408015989baf1e480617222d95c9413fbb038201782b150786b44cc2ba0e2fe6b532dc923086aaeb102e367a1b75a4a2d799f2ed277279d623e2d8b2a3e0bee WHIRLPOOL 6ed7671f6d7b00247e3b659380f1f845f015752330bdde4e2ae7db981b9f4b4cf14a9e010ef9932b6bc849866d281e9e7f22a5860c06478bd396197cfda53d35
+MISC metadata.xml 590 SHA256 ad69a23b85393e4f70a6594363f5674b1e4d65f435aba94089806a98f7e0490d SHA512 6a946177d4a8a65e5fca879cc48cd432661f069c1e1ac405655721ad69a88dd8749b64f2bf0ca8d899120a6d49ba57a1c933987640bf8c08634cdd59ba496fa5 WHIRLPOOL b196cf36807539f36febb2392b9b52532f3c46a67fd3685362a857997806463b3be83ca8276547c50540bd86930224a11227fcc3ca0b2b7a4a39cf6a3168ce67
diff --git a/net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild b/net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild
new file mode 100644
index 000000000000..2310def0f5ef
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="evm opencl"
+
+DEPEND="dev-lang/go:=
+ opencl? ( virtual/opencl )
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ use opencl && export GO_OPENCL=true
+
+ emake geth
+ use evm && emake evm
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+ use evm && dobin build/bin/evm
+}
diff --git a/net-p2p/go-ethereum/metadata.xml b/net-p2p/go-ethereum/metadata.xml
new file mode 100644
index 000000000000..3056bf45f275
--- /dev/null
+++ b/net-p2p/go-ethereum/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mathy@vanvoorden.be</email>
+ <name>Mathy Vanvoorden</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="evm">Build Ethereum Virtual Machine (EVM)</flag>
+ <flag name="opencl">Add OpenCL GPU mining support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ethereum/go-ethereum</remote-id>
+ </upstream>
+</pkgmetadata>