summaryrefslogtreecommitdiff
path: root/net-p2p/mktorrent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-p2p/mktorrent
reinit the tree, so we can have metadata
Diffstat (limited to 'net-p2p/mktorrent')
-rw-r--r--net-p2p/mktorrent/Manifest5
-rw-r--r--net-p2p/mktorrent/metadata.xml8
-rw-r--r--net-p2p/mktorrent/mktorrent-1.0-r1.ebuild33
3 files changed, 46 insertions, 0 deletions
diff --git a/net-p2p/mktorrent/Manifest b/net-p2p/mktorrent/Manifest
new file mode 100644
index 000000000000..622ea6463204
--- /dev/null
+++ b/net-p2p/mktorrent/Manifest
@@ -0,0 +1,5 @@
+DIST mktorrent-1.0.tar.gz 23089 SHA256 6f8e562af6366e0d9bde76e434f740b55722c6c3c555860dbe80083f9d1d119f SHA512 f103c8860c008796c2dc604fcabce7374264fd7814237fcad5f9dab0fe10e927b0e2d9b58e7462dd198265a7d83fe30fd68313c7dce4029d8c331a6f2d4622de WHIRLPOOL 2a907fe846ae5a35dbb38fbd6707a89121d34b9658f1afa682db14da9254cc58ed376fc23c834753409769643868294b0f1354fd7d9d567ec0cff49ee713b163
+EBUILD mktorrent-1.0-r1.ebuild 773 SHA256 bd45c909f1fc5995032f4a1d1ecca89d87e31bc059dddeee6b6b7c6c506751fb SHA512 0d0bb8c9cd8c14d7c6ecbd7bc7b59576ad1a1ba2ee27afba9ad2e2231e8fd48d47f657097d27f266ebe5a708e4c1e1cac1f9ddcad00838ccba757b89771e3b84 WHIRLPOOL f85db95884a0a1749e1a38e5febcc789ad9637853ffed09ea9b70467aa7280a73ba344cb71f21d904326ee167faf02a90351eb982ceb32947f63bd638d747cf3
+MISC ChangeLog 2463 SHA256 b548588c5d8ad39292660376ebaa8c294e388fdfca969b43fb99b45396e662ea SHA512 422a9a26eaf5c440003a3e5d3cd0bd7ca6dc413311a92af91071a2d14b23b891e47b458c9122ef993491d225adfedfa317dc0dcf33ca02558529bb0ff2dc2f2c WHIRLPOOL fe93adafc08d7dcb4ff81373848ad5fe1bffb204d0e49a721e98df6b091987014c583f0b8fd9fe893831fba7fec1cc24d73f802cd4e191cbc3b55ac1c9544013
+MISC ChangeLog-2015 2307 SHA256 79170f7cabb17c0f6c7a952a2cc6ea62c2fb5a80210c717bbb71b58fa027842e SHA512 83f94b8dff89f88006348f91a44f281a5dd395e4ac2ee49f19167a73e4b515b5264f6bcbcf63b027e590e9a56766cae4dd8e76dffa600d0e1845f62ffe7b740d WHIRLPOOL b00d5ab343a325e505936119efa73d026d47e35d984c7159558cc895ed5db29b4647e5fc35a4dfc0dbc0cd8adf62d6760bdc3b93b4014a2deb53e1f11838088c
+MISC metadata.xml 246 SHA256 6a1d6e3d973c49a448546ff17b94135248934cc5520224096bcbe862f1af6811 SHA512 ccfd5352b45fa0f1013a55f9daf8ce794904dd8c0d586d6ec732df83f776d28b78ca134c0a2cd5003c9d42b0b44419754cb5b19649100949536075c39a2b543c WHIRLPOOL 9a6752f83db1613496d4d8f4057e9ceb00ea824a2ca86d80adaa38878282cb95ac653007761c2a04708234b0610c7cddaaea20a957036e5754af498dc5e7c118
diff --git a/net-p2p/mktorrent/metadata.xml b/net-p2p/mktorrent/metadata.xml
new file mode 100644
index 000000000000..36ce80cda8c8
--- /dev/null
+++ b/net-p2p/mktorrent/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">mktorrent</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-p2p/mktorrent/mktorrent-1.0-r1.ebuild b/net-p2p/mktorrent/mktorrent-1.0-r1.ebuild
new file mode 100644
index 000000000000..fbf7e1b73e9b
--- /dev/null
+++ b/net-p2p/mktorrent/mktorrent-1.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
+HOMEPAGE="http://mktorrent.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="threads +ssl debug"
+
+RDEPEND="ssl? ( dev-libs/openssl:0 )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+ MAKEPARAM="USE_LONG_OPTIONS=1"
+ MAKEPARAM="${MAKEPARAM} USE_LARGE_FILES=1"
+ use debug && MAKEPARAM="${MAKEPARAM} DEBUG=1"
+ use ssl && MAKEPARAM="${MAKEPARAM} USE_OPENSSL=1"
+ use threads && MAKEPARAM="${MAKEPARAM} USE_PTHREADS=1"
+
+ emake ${MAKEPARAM}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}