summaryrefslogtreecommitdiff
path: root/net-p2p/nicotine+
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /net-p2p/nicotine+
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'net-p2p/nicotine+')
-rw-r--r--net-p2p/nicotine+/Manifest2
-rw-r--r--net-p2p/nicotine+/nicotine+-2.1.2.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/net-p2p/nicotine+/Manifest b/net-p2p/nicotine+/Manifest
index 6451bc3777db..c2f482f57f28 100644
--- a/net-p2p/nicotine+/Manifest
+++ b/net-p2p/nicotine+/Manifest
@@ -1,3 +1,5 @@
DIST nicotine+-2.0.1.tar.gz 5140065 BLAKE2B 01af7eb58ea6800c17042ef73b9caa8b3d5712e33226486e648fee824c0d0934440ee51f659199a5276f6a460005df89359b282b09aa07941c70e29bddc97a26 SHA512 0a16c0c289a4f4d54eba773ad40952baadf73333ea4a6b4a4524cc500d007f6de0bdd7a847e3f68978a3247c9bc4a6eab3b77db34605fda79da34c352e89a1b9
+DIST nicotine+-2.1.2.tar.gz 5091941 BLAKE2B 2fcfcc25645a194e1161502c1836d075732a833e1cca1f16cb939e960371c9a656c0044427ca381e8fb3d76de139af1f495b3c5ff208fe931571cfbe5ab0d219 SHA512 dc5ae656cb24efdd252475eefa63d471e44f9652650ca834acb358c195337c46c07ef5da873419d66235a8fbb3d2e290347aa47416c0017bea54423b485225c9
EBUILD nicotine+-2.0.1-r1.ebuild 873 BLAKE2B 077b529f6a880d238122952fc0d49cb75cfc5742bd533d650f12c5a96c85efd7d3786fea0ca71e40f1223db37f8f0841ad43766190c447d3f2a55d5f9c4ed9aa SHA512 42b4d6da425430544e42027afe647da0a1b6c556fb3513b032fce0f2fd794c55a85bb709019c2bf085ba1f84f37c485cfb73574ab818fc7a7be45c72d4d30d6f
+EBUILD nicotine+-2.1.2.ebuild 912 BLAKE2B 26b89d4276aa9f49c6593fc40392f0d3f6d00d8abe6559e480004c4de5c04de7994cd63a152d099bee44b5610f6f9f5a16edc6573224b58d7446a41a453ca3d1 SHA512 080960a43cf346a13e78d67e9bce1a91b6be329ebee2f5bcd762f1ff2562def006145d0ea89e6fc0cf8e12c3851cf6bbecfb342c6c598a45927237d1a82a3250
MISC metadata.xml 344 BLAKE2B 3e990579dbb468a2dc76bf5ea791367f8009fd3a21508de4ec40e7cc5d4ddca825488a139a63f7424a05e92246ed7e8d193eb6d2aa58a68244169ae77f588472 SHA512 a62b54ffb9368e5a5aa8a119146ae5330797ac7034b1d403bed87550b976daa25bcc7d68b2089122f287c8ecb1ca3f3679609eee3bfac518abbd251545adc3f2
diff --git a/net-p2p/nicotine+/nicotine+-2.1.2.ebuild b/net-p2p/nicotine+/nicotine+-2.1.2.ebuild
new file mode 100644
index 000000000000..96b50ea7f31d
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-2.1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
+SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pytaglib[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ ${DEPEND}
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nicotine-plus-${PV}"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/share/doc/nicotine" "${ED}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}