summaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent/qbittorrent-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
commit51536d2fe4697ba9114d611178bb9e20d3d5b729 (patch)
tree30b91d98e65985a575940ed49e756697c1f049c2 /net-p2p/qbittorrent/qbittorrent-9999.ebuild
parent4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (diff)
gentoo resync : 23.12.2017
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-9999.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild20
1 files changed, 19 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index a946e1511962..9ebc91b0bdb1 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils
+inherit cmake-utils gnome2-utils xdg-utils
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="https://www.qbittorrent.org/"
@@ -34,6 +34,7 @@ RDEPEND="
dbus? ( dev-qt/qtdbus:5 )
X? (
dev-qt/qtgui:5
+ dev-qt/qtsvg:5
dev-qt/qtwidgets:5
)"
DEPEND="${RDEPEND}
@@ -42,6 +43,13 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # bug 641382
+ sed -i -e "s/-Werror //" cmake/Modules/MacroQbtCompilerSettings.cmake || die
+}
+
src_configure() {
local mycmakeargs=(
-DSYSTEM_QTSINGLEAPPLICATION=ON
@@ -51,3 +59,13 @@ src_configure() {
)
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}