summaryrefslogtreecommitdiff
path: root/net-p2p/transmission-remote-gtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /net-p2p/transmission-remote-gtk
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'net-p2p/transmission-remote-gtk')
-rw-r--r--net-p2p/transmission-remote-gtk/Manifest2
-rw-r--r--net-p2p/transmission-remote-gtk/transmission-remote-gtk-1.6.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/net-p2p/transmission-remote-gtk/Manifest b/net-p2p/transmission-remote-gtk/Manifest
index 8745e6141fab..086a89742fba 100644
--- a/net-p2p/transmission-remote-gtk/Manifest
+++ b/net-p2p/transmission-remote-gtk/Manifest
@@ -1,4 +1,6 @@
AUX transmission-remote-gtk-1.5.1-libayatana-appindicator.patch 6013 BLAKE2B 6eeb01003daaf16c667819daa68a5839cf2a03aa92b521a6a4591845d93fd700495e988ed666a3b257126fba8b6084c79a0f2d46384b5902ee7b5b69be0032c9 SHA512 eaf7591fc3edf73c93e76278b073faa70cc1a492f4e97d1de4d2e054db4943d24a6c419852b27e81ccd315213754d176b9ecff63f36b138c753c2cb1866bf806
DIST transmission-remote-gtk-1.5.1.tar.xz 236804 BLAKE2B b2aeb4641a0ab55d2a212cdb04e8929c8c580e2f20a9a60fce7977404d1f0af64b5fc9ff2f9d7dd7d5744dddc34181d689c8dcab34cc23a0989a7e7f03d84395 SHA512 4488714f483dfbf539e39dc4b742127dc47799b255e7bc0e27c33aea92cea26d229616a484b566f5d85034d841a34546b113fc0428908ada4876840ff25cc824
+DIST transmission-remote-gtk-1.6.0.tar.xz 216648 BLAKE2B 256eee24f8060b526e6a7c7176c89e3d95451d28a684621d93100d245a6d62e3fc7a21e6e2de5ff1837d165113c2dc97ac6bf60b7e57da930636ea56e264c26c SHA512 351079d91cc5b33c7955103cbc28d1010bf3d18668689ff5b690ff2214d9e44cdd9f841ebe207260d31c332650d6ae05a0d9ceb7696861c8be5beeae4d0a08d5
EBUILD transmission-remote-gtk-1.5.1-r1.ebuild 1142 BLAKE2B 266f393c31c4ff84aecfd4782e91d2b54367a4b0e92b5b0c0b41d91382da02c10ac9c77690e55c6a271c80dd3a9b44f821f68eb8fbea60127c0e8fe75d681efe SHA512 6beddaacf2da7ff34e049bf4f32c3230d8f636f5a499556c4efacffe1db302a238e37197e8e365ddcca5878db4954558849190a7eb2c3479ac259f03341b5cec
+EBUILD transmission-remote-gtk-1.6.0.ebuild 921 BLAKE2B 9c2e3607156a4a18e5b04ea0605a4b5558662c5c0de4d5e78c1bc774fae2fdd91e3b1c7699af0112db47a0eab22dab7e662a59e8d8a259089597ebc516959d86 SHA512 08db216c77c6d839733de97f8d0100c8d3667f802188c1129ce7b864a0bb5d5d7b653daa7b4b9748fd6c184d03c7397bef111752cd75406058d2b048e3a3c8de
MISC metadata.xml 601 BLAKE2B 588f973d7e3c08f4b3440269c1edcfcc52d817405e93715d04a2a4e5043362a7e7aabb645f3b5195a9671db14268d3483fab6068ccf04372ea0a3b1500b07ca3 SHA512 10a8719e58b9aef4d3e804a301bca0859da2b566424f3ece603e00617127a587a97a29afaf39b72c951dcb28b695dff560b08ed8aa91f6ad74b034a127e7e1de
diff --git a/net-p2p/transmission-remote-gtk/transmission-remote-gtk-1.6.0.ebuild b/net-p2p/transmission-remote-gtk/transmission-remote-gtk-1.6.0.ebuild
new file mode 100644
index 000000000000..722a196e1260
--- /dev/null
+++ b/net-p2p/transmission-remote-gtk/transmission-remote-gtk-1.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="GTK+ client for management of the Transmission BitTorrent client, over HTTP RPC"
+HOMEPAGE="https://github.com/transmission-remote-gtk/transmission-remote-gtk"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="appindicator geoip"
+
+# RESTRICT="test"
+
+# FIXME: bundles rss-glib-0.2.3
+RDEPEND="
+ net-libs/libsoup:3.0
+ >=dev-libs/glib-2.70:2
+ >=dev-libs/json-glib-1.2.8
+ >=x11-libs/gtk+-3.22:3
+ appindicator? ( dev-libs/libayatana-appindicator )
+ geoip? ( dev-libs/geoip )
+"
+DEPEND="${RDEPEND}
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature geoip)
+ $(meson_feature appindicator libappindicator)
+ )
+ meson_src_configure
+}