summaryrefslogtreecommitdiff
path: root/net-p2p/vuze
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /net-p2p/vuze
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'net-p2p/vuze')
-rw-r--r--net-p2p/vuze/Manifest1
-rw-r--r--net-p2p/vuze/vuze-5.7.6.0-r2.ebuild144
2 files changed, 145 insertions, 0 deletions
diff --git a/net-p2p/vuze/Manifest b/net-p2p/vuze/Manifest
index d6e36adc52be..ef37fae032c4 100644
--- a/net-p2p/vuze/Manifest
+++ b/net-p2p/vuze/Manifest
@@ -12,5 +12,6 @@ AUX vuze-5.7.6.0-unbundle-commons.patch 5156 BLAKE2B 641a0264521e97d808046a9d76c
AUX vuze.desktop 164 BLAKE2B fa225e36d05244707ff0c0e72d2455cdc3843a2e1c7633f43f902c6372fccb14bb4baf77f07a00314a02f02e6ee682a09f95d75ff12ea0ce16d6681df0d9371e SHA512 4d68ed3af2c983435d1014ea1281076fd5d1171b23ebbe7cc8d7e6c45b39b036e7f4660fce81481ba3b7bddd29c8255ce22bbb79230f77c6ecfdecb24736d480
DIST Vuze_5760_source.zip 10928786 BLAKE2B df8bbb797f2a1b0c92bc19be122a0da3b6382dc80f51bb652026e3d68503d19ddb3b16e3bc6c333f12c8bfa52b014f85b0812fd5683fe4553040feff39ab77d8 SHA512 c4c1cc84d3c8ce31772bd677f105f6d00e0a6d867d6890b6a834c9e189bb1752e065a64308cdf1315bace1ca4783843553b45fbf3c15240c57584e2926ba92c5
EBUILD vuze-5.7.6.0-r1.ebuild 4071 BLAKE2B 672f71c9acfdb81cc985a6fba4b35d109d0ac763d091180509156bacb3f1e3c722907b4e8ed587421579a7d3c21e5c30f7636386c8d3a8f188ddd119948904a2 SHA512 845b94ea88e08ba71b70368902d285f5eec8c889a149954b49c5bac650cc446ff441e767e12a1200a0e31894f551b7865c4eb8624adcbe3e7921b1a9763c0226
+EBUILD vuze-5.7.6.0-r2.ebuild 4068 BLAKE2B cc886730154ee78f0a29f3e92dc989a6ab2e25bebe9ac1ffe18b24dc1118289152b573620ecc3bd6f0e044dc18c706cb7346d5a019f8db78eeee30e7e81fb546 SHA512 d9b7faa5b51d359fce3a5812ceb9c3c6069bc8952d684bf0f58e72b119bb2e7682d3ec5d4ed7485fa83ef75cbbf281e8e0e546de5f5b8a4041155233ccde1266
EBUILD vuze-5.7.6.0.ebuild 4110 BLAKE2B d2318a6f7b57f629ac3211256b24475012133c9ac102020d88ac0681af93d7d746cf317e07709f1f328f8a72cf4ffc852677424e0ffb1cafa367019cd147602a SHA512 de63a2b00b95cc31f25e20dde85791721fcfee763fa491ec2c973b5d1a496d3327233bf3839afe41e3f11836b4943e97cfa23f6828f8f0d6c82c9b1fe58c5f3d
MISC metadata.xml 313 BLAKE2B fc77cc23994c00f76b282bfb170062f085fb1c83ced23e4a38d141acb5e2c4d259988541a0538de48dfe7e943132d4446467df8745b1e171ecdf3ece1f2e0eff SHA512 f77617dfe493bf5cc08c1db751bb8eed8275938f57c9fbe19584adf19bdaa4481c9bf3ece012859641f0e811ae2ce4ce058899a6c3075defc738c25e21b300d1
diff --git a/net-p2p/vuze/vuze-5.7.6.0-r2.ebuild b/net-p2p/vuze/vuze-5.7.6.0-r2.ebuild
new file mode 100644
index 000000000000..32974b2ba0c8
--- /dev/null
+++ b/net-p2p/vuze/vuze-5.7.6.0-r2.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="source"
+
+inherit desktop edos2unix java-pkg-2 java-ant-2 xdg-utils
+
+MY_PV=$(ver_rs 1- "")
+MY_SRC="Vuze_${MY_PV}"
+
+DESCRIPTION="BitTorrent client in Java, formerly called Azureus"
+HOMEPAGE="http://www.vuze.com/"
+SRC_URI="mirror://sourceforge/azureus/${PN}/${MY_SRC}/${MY_SRC}_source.zip"
+LICENSE="GPL-2 BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+# bundles parts of http://www.programmers-friend.org/
+# bundles bcprov - 1.37 required but not in the tree
+CDEPEND="
+ dev-java/log4j:0
+ dev-java/swt:4.10[cairo]
+ dev-java/commons-cli:1
+ dev-java/commons-text:0
+ dev-java/json-simple:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+# does not compile with java 11, uses classes deprecated even in java 8
+DEPEND="
+ ${CDEPEND}
+ app-arch/unzip
+ dev-util/desktop-file-utils
+ virtual/jdk:1.8"
+
+PDEPEND="~net-p2p/vuze-coreplugins-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.3.0.0-java5.patch
+ "${FILESDIR}"/${PN}-5.3.0.0-remove-classpath.patch
+ "${FILESDIR}"/${PN}-5.3.0.0-disable-shared-plugins.patch
+ "${FILESDIR}"/${PN}-5.7.2.0-disable-osx.patch
+ "${FILESDIR}"/${PN}-5.3.0.0-disable-updaters.patch
+ "${FILESDIR}"/${PN}-5.3.0.0-unbundle-json.patch
+ "${FILESDIR}"/${PN}-5.7.6.0-commons-lang.patch
+)
+
+src_unpack() {
+ mkdir -p "${S}" || die
+ cd "${S}" || die
+ unpack ${A}
+
+ # build.xml disappeared from 4.4.0.0 although it was there in 4.3.1.4
+ if [[ -f build.xml ]]; then
+ die "upstream has build.xml again, don't overwrite"
+ fi
+ cp "${FILESDIR}"/build.xml "${S}" || die "failed to copy build.xml"
+}
+
+src_prepare() {
+ # upstream likes randomly changing a subset of files to CRLF every release
+ edos2unix $(find "${S}" -type f -name "*.java")
+
+ default
+
+ # OSX / Windows
+ rm "${S}"/org/gudy/azureus2/ui/swt/osx/CarbonUIEnhancer.java || die
+ rm "${S}"/org/gudy/azureus2/ui/swt/osx/Start.java || die
+ rm "${S}"/org/gudy/azureus2/ui/swt/win32/Win32UIEnhancer.java || die
+
+ # Tree2 file does not compile on linux
+ rm -rf "${S}"/org/eclipse || die
+ # Bundled apache
+ rm -rf "${S}"/org/apache || die
+ # Bundled json
+ rm -rf "${S}"/org/json || die
+ # Bundled bcprov
+ # currently disabled - requires bcprov 1.37
+ #rm -rf "${S}"/org/bouncycastle || die
+
+ rm -rf "${S}"/org/gudy/azureus2/ui/console/multiuser/TestUserManager.java || die
+ mkdir -p "${S}"/build/libs || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="swt-4.10,json-simple,log4j,commons-cli-1,commons-text"
+
+src_compile() {
+ local mem
+ use amd64 && mem="320"
+ use x86 && mem="256"
+ use ppc && mem="192"
+ use ppc64 && mem="256"
+ use sparc && mem="320"
+ export ANT_OPTS="-Xmx${mem}m"
+ java-pkg-2_src_compile
+
+ # bug #302058 - build.xml excludes .txt but upstream jar has it...
+ jar uf dist/Azureus2.jar ChangeLog.txt || die
+}
+
+src_install() {
+ java-pkg_dojar dist/Azureus2.jar
+ dodoc ChangeLog.txt
+
+ java-pkg_dolauncher "${PN}" \
+ --main org.gudy.azureus2.ui.common.Main -pre "${FILESDIR}/${PN}-4.1.0.0-pre" \
+ --java_args '-Dazureus.install.path=/usr/share/vuze/ ${JAVA_OPTIONS}' \
+ --pkg_args '--ui=${UI}'
+ dosym vuze /usr/bin/azureus
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=204132
+ java-pkg_register-environment-variable MOZ_PLUGIN_PATH /usr/lib/nsbrowser/plugins
+
+ newicon "${S}"/org/gudy/azureus2/ui/icons/a32.png vuze.png
+ domenu "${FILESDIR}"/${PN}.desktop
+
+ use source && java-pkg_dosrc "${S}"/{com,edu,org}
+}
+
+pkg_postinst() {
+ ewarn "Running Vuze as root is not supported and may result in untracked"
+ ewarn "updates to shared components and then collisions on updates"
+ echo
+ elog "Vuze was formerly called Azureus and many references to the old name remain."
+ elog
+ elog "After running Vuze for the first time, configuration options will be"
+ elog "placed in '~/.azureus/gentoo.config'."
+ elog
+ elog "If you need to change some startup options, you should modify this file"
+ elog "rather than the startup script. You can enable the console UI by"
+ elog "editing this config file."
+ echo
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}