summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-04 11:22:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-04 11:22:15 +0100
commit7f6382ebb44b75c53021d4c4ab77d6b34aed21ac (patch)
tree4d92ef3af5a26ff8a8a5a1ec4f21d18c65f56fe2 /net-p2p
parent41e5b5c1f11820df590e0a245bbddf224bc07823 (diff)
gentoo auto-resync : 04:04:2023 - 11:22:14
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Manifest.gzbin6916 -> 6918 bytes
-rw-r--r--net-p2p/mldonkey/Manifest1
-rw-r--r--net-p2p/mldonkey/mldonkey-3.1.7-r4.ebuild136
3 files changed, 137 insertions, 0 deletions
diff --git a/net-p2p/Manifest.gz b/net-p2p/Manifest.gz
index a20e61e6c67b..a3f0ef175a1a 100644
--- a/net-p2p/Manifest.gz
+++ b/net-p2p/Manifest.gz
Binary files differ
diff --git a/net-p2p/mldonkey/Manifest b/net-p2p/mldonkey/Manifest
index 3ceed6950401..c3e5f232c6c8 100644
--- a/net-p2p/mldonkey/Manifest
+++ b/net-p2p/mldonkey/Manifest
@@ -4,4 +4,5 @@ AUX mldonkey.initd 1488 BLAKE2B 062bc7f00dc798bab4da0a0bdef87c5d2a3388a67ceddbbb
AUX mldonkey.service 274 BLAKE2B 2ff70c85d4f8f07435ce973d4b8bd3f90999b433187060ebb1500f9964a5df7b3aa05cd0391efa748201b5d3ce496f985b971200bdf19e36a9edc6cf66f24fa2 SHA512 62fab67f8ca13e539b3ecfefe8d16a8cfbaad296f1a9d3f16dea8dcaa189946f2631545c940bb88e29ae119ad7285fbd7cd1cd047fe7a85b746d1ee36e13d8ce
DIST mldonkey-3.1.7-2.tar.bz2 2801815 BLAKE2B f914648b4e2a358e51518f3b58dc0df803cdb28d7706783504644266690514c17c2cae0688011073391db221eb8f38c7cbaf1e913220d824e41ca2e23d4c8587 SHA512 11cb0fa0db95e918c291009f4121a1b34cf485e5ac6826a72a4dc520dd78d21ced40d205fa26eb451c7d3eb31f2193cbb64e46c99c85dc932762c1bcc4da4934
EBUILD mldonkey-3.1.7-r3.ebuild 4857 BLAKE2B 8f6bdde47da366f77b82a483c90230df04d808d44c7bf8f7a0ece44314b34ea84cb788146f391a5aa9bc232680f425766f8e60b68985b1838ebea73bac5fad34 SHA512 15043f2496ff641e0fd64aa06985862614b416c21508bbc9093e80d0a059d3b3a6646e479d32a2bab567efe43641a5d5bb105bf51806c2431853f51918176b7c
+EBUILD mldonkey-3.1.7-r4.ebuild 3598 BLAKE2B 1a4ce653ee4925c6081a488fa2bc362a67957bced94bd47147c894cf42b965a8dd642c4bb77b3bc0ca2166dd593ca07a11071b28d4d1628586003c90f9bab1f3 SHA512 8dfd0e5c20f3b330ef4ec4fd106ec630dc10fdb3c6ba5f233d53eb310d38173a60662ebc77ae46de0a84070eace5feb0492fea0d9d90d45c7a7b98213ccf6312
MISC metadata.xml 810 BLAKE2B 111ab6f9b165a59465beb7ac8c7cdf6651c72484dc2a5f77f0b6cbad44d6a71d44ca27aeb3785af9b2cbb0a5ae624b784db88b7790abdae98b36bf393a1cca08 SHA512 e59c710af7fab80b1da8ec97acd5d43cf8e725bc97c6b1d6257134e689ef6abdf9a8b5716131e512ee1ae4abc1fdb2f15a36dc09f40ef7aa726d414e2e0614a6
diff --git a/net-p2p/mldonkey/mldonkey-3.1.7-r4.ebuild b/net-p2p/mldonkey/mldonkey-3.1.7-r4.ebuild
new file mode 100644
index 000000000000..cb2eae216dbe
--- /dev/null
+++ b/net-p2p/mldonkey/mldonkey-3.1.7-r4.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="Multi-network P2P application written in Ocaml, with Gtk, web & telnet interface"
+HOMEPAGE="http://mldonkey.sourceforge.net/ https://github.com/ygrek/mldonkey"
+SRC_URI="https://github.com/ygrek/mldonkey/releases/download/release-${PV//./-}-2/${P}-2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+
+IUSE="bittorrent doc fasttrack gd gnutella magic +ocamlopt upnp"
+
+RDEPEND="dev-lang/perl
+ dev-ml/camlp4:=
+ gd? ( media-libs/gd:2=[truetype] )
+ magic? ( sys-apps/file )
+ upnp? (
+ net-libs/libnatpmp
+ net-libs/miniupnpc:=
+ )
+ acct-user/p2p
+ app-arch/bzip2
+ sys-libs/zlib
+"
+# Can't yet use newer OCaml
+# -unsafe-string usage:
+# https://github.com/ygrek/mldonkey/issues/46
+DEPEND="${RDEPEND}
+ <dev-lang/ocaml-4.10:=[ocamlopt?]
+ bittorrent? (
+ || (
+ <dev-lang/ocaml-4.06[ocamlopt?]
+ dev-ml/num
+ )
+ )"
+
+RESTRICT="!ocamlopt? ( strip )"
+
+PATCHES=( "${FILESDIR}/cpp17-byte-namespace.patch" )
+
+S="${WORKDIR}/${P}-2"
+
+pkg_setup() {
+ # dev-lang/ocaml creates its own objects but calls gcc for linking, which will
+ # results in relocations if gcc wants to create a PIE executable
+ if gcc-specs-pie ; then
+ append-ldflags -nopie
+ ewarn "Ocaml generates its own native asm, you're using a PIE compiler"
+ ewarn "We have appended -nopie to ocaml build options"
+ ewarn "because linking an executable with pie while the objects are not pic will not work"
+ fi
+}
+
+src_prepare() {
+ cd config || die
+ eautoconf
+ cd .. || die
+ if ! use ocamlopt; then
+ sed -i -e "s/ocamlopt/idontwantocamlopt/g" "${S}/config/configure" || die "failed to disable ocamlopt"
+ fi
+
+ default
+}
+
+src_configure() {
+ local myconf=()
+
+ local my_extra_libs
+ if use gd; then
+ my_extra_libs="-lpng"
+ fi
+
+ econf LIBS="${my_extra_libs}"\
+ --sysconfdir=/etc/mldonkey \
+ --sharedstatedir=/var/mldonkey \
+ --localstatedir=/var/mldonkey \
+ --enable-checks \
+ --disable-batch \
+ $(use_enable bittorrent) \
+ $(use_enable fasttrack) \
+ $(use_enable gnutella) \
+ $(use_enable gnutella gnutella2) \
+ $(use_enable gd) \
+ $(use_enable magic) \
+ $(use_enable upnp upnp-natpmp) \
+ --disable-force-upnp-natpmp \
+ --disable-gui
+ ${myconf[@]}
+}
+
+src_compile() {
+ export OCAMLRUNPARAM="l=256M"
+ emake -j1 # Upstream bug #48
+ emake utils
+}
+
+src_install() {
+ local myext i
+ use ocamlopt || myext=".byte"
+ for i in mlnet mld_hash get_range copysources subconv; do
+ newbin "${i}${myext}" "${i}"
+ done
+ use bittorrent && newbin "make_torrent${myext}" make_torrent
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newconfd "${FILESDIR}/mldonkey.confd" mldonkey
+ newinitd "${FILESDIR}/mldonkey.initd" mldonkey
+
+ if use doc ; then
+ docompress -x "/usr/share/doc/${PF}/scripts" "/usr/share/doc/${PF}/html"
+
+ dodoc distrib/ChangeLog distrib/*.txt docs/*.txt docs/*.tex docs/*.pdf docs/developers/*.{txt,tex}
+
+ docinto scripts
+ dodoc distrib/{kill_mldonkey,mldonkey_command,mldonkey_previewer,make_buginfo}
+
+ docinto html
+ dodoc docs/*.html
+
+ docinto html/images
+ dodoc docs/images/*
+ fi
+}
+
+pkg_postinst() {
+ if [ -f /etc/conf.d/mldonkey ] && grep -qE "^(BASEDIR|SUBDIR|LOW_DOWN|LOW_UP|HIGH_DOWN|HIGH_UP|SERVER|PORT|TELNET_PORT|USERNAME|PASSWORD|MLDONKEY_TIMEOUT)=" /etc/conf.d/mldonkey; then
+ ewarn "The following settings are deprecated and will be ignored,"
+ ewarn "please remove them from /etc/conf.d/mldonkey:"
+ ewarn "LOW_DOWN LOW_UP HIGH_DOWN HIGH_UP SERVER PORT TELNET_PORT USERNAME PASSWORD MLDONKEY_TIMEOUT"
+ fi
+}