summaryrefslogtreecommitdiff
path: root/net-print/apsfilter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-print/apsfilter
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-print/apsfilter')
-rw-r--r--net-print/apsfilter/Manifest2
-rw-r--r--net-print/apsfilter/apsfilter-7.2.8-r1.ebuild43
2 files changed, 29 insertions, 16 deletions
diff --git a/net-print/apsfilter/Manifest b/net-print/apsfilter/Manifest
index f451c186749d..565690a6da9d 100644
--- a/net-print/apsfilter/Manifest
+++ b/net-print/apsfilter/Manifest
@@ -1,3 +1,3 @@
DIST apsfilter-7.2.8.tar.bz2 310587 BLAKE2B aae44a7e79157d3ddf9ce56fe51ae90106eb952d536658efe0f19dfcbe5f0d5c7dd078e3bb5044433e250df6b9289a08a466d6e9fc77c91d540daf07a70bf197 SHA512 ca07e7eb620a95b08fb912e899520d5ff85613eb3d1f712e1d38a66cf5b84516dbb35e3e40ef75ac10d1e717cfc2f49930a0f0873fee451d495c8ae572072012
-EBUILD apsfilter-7.2.8-r1.ebuild 1162 BLAKE2B ca9d552654d1f02ff411074e27014fb5f8871810b368c7be7964d8e55d47c25dd7c3209899d5ab995179dd0db1e5bb7425437f22e2bf5331dc88cd5d2e8fcedd SHA512 bb60ebb237a9bb9b08694ac3633443b2f7ba10386ad2457faa008de651554b32179af730e3957694abb94b752a1d71d6c260557c3255c3ca27bb35d7daae35ba
+EBUILD apsfilter-7.2.8-r1.ebuild 1211 BLAKE2B 54ca8fdeaf8438db0db91f30ba2fd390c23af65594199b8b8ded028c1ae9545109f220bfebd5e8bb65e1d591bdef7eb91bc7810e0929ded26df80e9e053882fd SHA512 e88cb423635985cd4e801a909eeb37a59f6256bdf485adddbe2b9d5efd6a010bbbd099f66fd74ee3275d1e9677696ba60514a052be92b2e99932743766a28031
MISC metadata.xml 255 BLAKE2B 06f078acf8e4416705c8bad8b4802a44592eb962c08c050e11332bfa97564fafdf08754ab056eb813f6baeaa6cdfaf5d71672455d77e74045f86098c221d5136 SHA512 c6c5f966cfbe396fde1b15334442de9e0004b44c4b48775588b0b25a058ad1751252761370c9c254280e97561fa6306f5aa0cc7959c675d4ee11f7f95d777a36
diff --git a/net-print/apsfilter/apsfilter-7.2.8-r1.ebuild b/net-print/apsfilter/apsfilter-7.2.8-r1.ebuild
index dcc618969c3a..4f7f15844cab 100644
--- a/net-print/apsfilter/apsfilter-7.2.8-r1.ebuild
+++ b/net-print/apsfilter/apsfilter-7.2.8-r1.ebuild
@@ -1,42 +1,55 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
DESCRIPTION="Apsfilter Prints So Fine, It Leads To Extraordinary Results"
HOMEPAGE="http://www.apsfilter.org"
SRC_URI="http://www.apsfilter.org/download/${P}.tar.bz2"
+S="${WORKDIR}/${PN}"
+
KEYWORDS="~alpha ~amd64 ppc sparc x86"
IUSE="cups"
SLOT="0"
LICENSE="GPL-2"
-RDEPEND="|| ( net-print/cups net-print/lprng )
+RDEPEND="
app-text/ghostscript-gpl
>=app-text/psutils-1.17
>=app-text/a2ps-4.13b-r4
+ net-print/cups
virtual/awk
virtual/imagemagick-tools
virtual/mta"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/${PN}
-
src_configure() {
- # assume thet lprng is installed if cups isn't USEd
- use cups && \
- myconf="--with-printcap=/etc/cups/printcap --with-spooldir=/var/spool/cups" || \
- myconf="--with-printcap=/etc/lprng/printcap"
+ local myconf=
+
+ # assume that lprng is installed if cups isn't USEd
+ if use cups ; then
+ myconf="--with-printcap=/etc/cups/printcap --with-spooldir=/var/spool/cups"
+ else
+ myconf="--with-printcap=/etc/lprng/printcap"
+ fi
# econf doesn't work here :(
- ./configure --prefix=/usr --mandir=/usr/share/man \
- --docdir=/usr/share/doc/${PF} --sysconfdir=/etc ${myconf} || die
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc/${PF} \
+ --sysconfdir=/etc \
+ "${myconf} ${EXTRA_ECONF}" \
+ || die
}
src_install() {
- emake DESTDIR="${D}" install
- dosym /usr/share/apsfilter/SETUP /usr/bin/apsfilter
- use cups && \
- dosym /etc/cups/printcap /etc/printcap || \
- dosym /etc/lprng/printcap /etc/printcap
+ emake DESTDIR="${ED}" install
+ dosym ../share/apsfilter/SETUP /usr/bin/apsfilter
+
+ if use cups ; then
+ dosym ../cups/printcap /etc/printcap
+ else
+ dosym ../lprng/printcap /etc/printcap
+ fi
}