summaryrefslogtreecommitdiff
path: root/net-print/brlaser/brlaser-6.2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-12 13:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-12 13:08:05 +0000
commit4c4e8e9bf6d1ef49be600d77fcbbd7be716aece7 (patch)
treec854c61724b1a5430091a4512ef763d26efe5938 /net-print/brlaser/brlaser-6.2.6.ebuild
parent669bfefc6b9cafab1e89f098b21cf0f89c12d995 (diff)
gentoo auto-resync : 12:01:2024 - 13:08:05
Diffstat (limited to 'net-print/brlaser/brlaser-6.2.6.ebuild')
-rw-r--r--net-print/brlaser/brlaser-6.2.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-print/brlaser/brlaser-6.2.6.ebuild b/net-print/brlaser/brlaser-6.2.6.ebuild
new file mode 100644
index 000000000000..683dbf0ec1a4
--- /dev/null
+++ b/net-print/brlaser/brlaser-6.2.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Brother laser printer driver"
+HOMEPAGE="https://github.com/Owl-Maintain/brlaser/"
+SRC_URI="https://github.com/Owl-Maintain/brlaser/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# https://github.com/Owl-Maintain/brlaser/blob/master/src/main.cc#L5C1-L8C39
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-print/cups"
+RDEPEND="
+ ${DEPEND}
+ app-text/ghostscript-gpl
+"
+
+src_prepare() {
+ # Don't clobber toolchain defaults
+ sed -i -e '/-D_FORTIFY_SOURCE=2/d' CMakeLists.txt || die
+
+ cmake_src_prepare
+}