summaryrefslogtreecommitdiff
path: root/net-print/c2esp/c2esp-27.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-29 20:19:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-29 20:19:23 +0100
commit12bb627384ddfd47382b9f1b6464481a58d01ebb (patch)
treef9760c04ccd4fcd7de214e2acd5b0e43fb530aa9 /net-print/c2esp/c2esp-27.ebuild
parent5fdd950c7ae03e12746a45c86d85861beaacc846 (diff)
gentoo resync : 29.08.2018
Diffstat (limited to 'net-print/c2esp/c2esp-27.ebuild')
-rw-r--r--net-print/c2esp/c2esp-27.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-print/c2esp/c2esp-27.ebuild b/net-print/c2esp/c2esp-27.ebuild
new file mode 100644
index 000000000000..69e58fbb92f9
--- /dev/null
+++ b/net-print/c2esp/c2esp-27.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A CUPS filter for Kodak ESP printers"
+HOMEPAGE="https://sourceforge.net/projects/cupsdriverkodak"
+SRC_URI="mirror://sourceforge/cupsdriverkodak/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND=">=media-libs/jbigkit-2.0-r1:=
+ >=net-print/cups-1.6
+ sys-libs/zlib:="
+
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/0001-Fix-various-missing-includes.patch
+)
+
+src_configure() {
+ # Don't trust cups-config in case ROOT!=/.
+
+ econf \
+ --with-cupsfilterdir="${EPREFIX}"/usr/libexec/cups/filter \
+ --with-cupsdatadir="${EPREFIX}"/usr/share/cups
+}