summaryrefslogtreecommitdiff
path: root/net-print/cups-pdf/cups-pdf-2.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-print/cups-pdf/cups-pdf-2.6.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-print/cups-pdf/cups-pdf-2.6.1.ebuild')
-rw-r--r--net-print/cups-pdf/cups-pdf-2.6.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-print/cups-pdf/cups-pdf-2.6.1.ebuild b/net-print/cups-pdf/cups-pdf-2.6.1.ebuild
new file mode 100644
index 000000000000..edd5a5eba833
--- /dev/null
+++ b/net-print/cups-pdf/cups-pdf-2.6.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Provides a virtual printer for CUPS to produce PDF files"
+HOMEPAGE="http://www.cups-pdf.de/"
+SRC_URI="http://www.cups-pdf.de/src/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="net-print/cups
+ app-text/ghostscript-gpl"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd "${S}"/src
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die "Compilation failed."
+}
+
+src_install () {
+ exeinto /usr/libexec/cups/backend
+ exeopts -m0700
+ doexe src/cups-pdf
+
+ insinto /usr/share/cups/model
+ doins extra/CUPS-PDF.ppd
+
+ insinto /etc/cups
+ doins extra/cups-pdf.conf
+
+ dodoc ChangeLog README
+ newdoc contrib/Contents contrib_Contents
+}
+
+pkg_postinst () {
+ elog "Please view both the README and contrib_Contents files"
+ elog "as you may want to adjust some settings and/or use"
+ elog "contributed software. In the latter case you may need"
+ elog "to extract some files from the ${P} distfile."
+}