summaryrefslogtreecommitdiff
path: root/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-26 19:38:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-26 19:38:09 +0000
commit7ab79528a3e9a77497eb58022bb0e775e7440885 (patch)
tree10bac8ed3339f6c09a7afc5111ff705b708831d1 /net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.3.ebuild
parentc25546f65119d2fb9a2f79588fd130d62989eddb (diff)
gentoo auto-resync : 26:12:2023 - 19:38:09
Diffstat (limited to 'net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.3.ebuild')
-rw-r--r--net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.3.ebuild b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.3.ebuild
new file mode 100644
index 000000000000..e56f27074520
--- /dev/null
+++ b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm
+
+DESCRIPTION="Epson Inkjet Printer Driver (ESC/P-R)"
+HOMEPAGE="https://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+SRC_URI="https://download3.ebz.epson.net/dsc/f/03/00/15/47/99/379a81c231d0b6b3dfb3db2032ff6e23f7ccaa34/${P}-1.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+DEPEND="net-print/cups"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/1.6.5-warnings.patch"
+ "${FILESDIR}/${PN}-1.7.7-fnocommon.patch"
+)
+
+src_unpack() {
+ rpm_src_unpack "${A}"
+}
+
+src_configure() {
+ econf --disable-shared
+
+ # Makefile calls ls to generate a file list which is included in Makefile.am
+ # Set the collation to C to avoid automake being called automatically
+ unset LC_ALL
+ export LC_COLLATE=C
+}
+
+src_install() {
+ emake -C ppd DESTDIR="${D}" install
+ emake -C src DESTDIR="${D}" install
+ einstalldocs
+}