summaryrefslogtreecommitdiff
path: root/net-print/hplip-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
commit6957f5c65b02bba533954eabc0b62f5de36be206 (patch)
tree21d8ab8f61dffd9cccc82d0badb68982516a6855 /net-print/hplip-plugin
parente91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (diff)
gentoo resync : 10.04.2018
Diffstat (limited to 'net-print/hplip-plugin')
-rw-r--r--net-print/hplip-plugin/Manifest2
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.18.3.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index cc12599c6b51..868e7c368054 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,3 +1,5 @@
DIST hplip-3.17.10-plugin.run 2062947 BLAKE2B 86f15193a751794eb64acfbaf1b42151c34336603d4d592cc84a375ccca4e7be4177d3dda76fc153ac0a6898eff24174df43256450cd81ae8ad4d4f6abd69ade SHA512 98eef413b122527c4a7860b621baf11c04ec9d7f4e43ce4f36e7822a633c64b3d98cbc86cd7d305c74d9a49a4159ebd7280d652e1ba430cad4cc70f66d23ee07
+DIST hplip-3.18.3-plugin.run 2065610 BLAKE2B 820f390c7c5f66943b12545ebe33742909b41f3f2d9389a811f4aed983e88dec22d44288692a9de5014f9093173b726c3e792124327e4bd774cbc66070e113c4 SHA512 d1bf83476aa56748f9e808f6ae9dd66b761c7674fdc0c960636102e7f263347fe8553a14e9ddbe6dfacc52fddbe4e47b5a9c1c01f07010444e656751272d73f2
EBUILD hplip-plugin-3.17.10.ebuild 1545 BLAKE2B 31f321fa6f038a90c5f2487b9d6242d7fea58fe9cf6af69ac8dc2eabd3788d09e57ab325737ca71ea5e7b26a686c83bb39448d3bba71f47500c16f2aae855d6c SHA512 e9c19899a37e95c2a61cf432e0c2557dbe8a8ff302da5f39475f97c89d362ab0da51a28818f457633c7d1b2a782703349d798d0e9526f2ef31346f39ed77a6cf
+EBUILD hplip-plugin-3.18.3.ebuild 1545 BLAKE2B caad3c84d51702bf101bdb240e4e10bca75923dd5ba2d94fa8ac034495aa088fca40f1ad39e102e17c3227ab918792cff4349d128c08b89cf362951d853d4d7c SHA512 167d560a9cc88ca1fed36fae85fad9ceec7186e61d6f2504e07afd82bb6afedab040bb93241f352e425e1fd67f982fd81bacb86a922c534ad34600e6bfcc7d1f
MISC metadata.xml 334 BLAKE2B 8f1a0784c57af6204db98f443bdb09df2a6432674d711a5ecf577c20e29f04a030549ea19c6e04f51cd9a36e60a6da94bebafbfcc10d52da87109e59c32d42ee SHA512 105a5442ba05b94b2886f9075bd89268d4f2e0567ad69a637a1bd7d7d0eafdc280dfdb198aab5d72525300a9be0d4ad78f6bfe6398c896cc9de0f591651d102c
diff --git a/net-print/hplip-plugin/hplip-plugin-3.18.3.ebuild b/net-print/hplip-plugin/hplip-plugin-3.18.3.ebuild
new file mode 100644
index 000000000000..b96c3ec3601d
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.18.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit udev unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
+SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_escl.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_makeself "hplip-${PV}-plugin.run"
+}
+
+src_install() {
+ local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ mkdir -p "${ED}/var/lib/hp/"
+ cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}