summaryrefslogtreecommitdiff
path: root/net-print/hplip-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /net-print/hplip-plugin
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'net-print/hplip-plugin')
-rw-r--r--net-print/hplip-plugin/Manifest2
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.18.10.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 0057af6283da..d0b675d4ef22 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,3 +1,5 @@
+DIST hplip-3.18.10-plugin.run 7324725 BLAKE2B 62e7ba436a32c70a0ad0ae009f192035e1152689ce0e032ec45fae11e8ff0470a2c04a5b243e1857dceb6bd65de2381291f6b1bdcdf8fae5ca6ebb92da15823c SHA512 86f393689d1afbaa43ec049d7c1150acd210ce100adbae8ec6f354d215d8bf2f6cc26acefdab840f933b2f5e11f8a731b79b99b528b7a3e455f283b0f7438a07
DIST hplip-3.18.6-plugin.run 2065663 BLAKE2B 501a37dd504250225ddad9712259e0e1b564aa034e433f24d277c5609fa95580417da1a0ae040a4624ff48806a3b34ec56ff31aed843e9f0f0b68b304d2ebd9e SHA512 7b5eb2f43dd014df25ccd9e72dd7efc069db47921f2de650b2ff993dbee60056063edeee6593be7d35019212daf623fff9696b13508a808db92128f5c81bde76
+EBUILD hplip-plugin-3.18.10.ebuild 1635 BLAKE2B ae1570a85138b53a21ee01c9b6c2eed85b4f22f4040666289d2bf52bdc5df0ef063574e767109fec86d3f24765149774918e9aa39247df5d0b2af56b25dfffcc SHA512 e039e8f25c210638d6098e06e51861b5c35400554fba867abd533f2aa89584abc6c62546bdad04b5fb4ce6dc61bc9d33ef9b7a0ae9d3ed3a7b3b42c45c2888d2
EBUILD hplip-plugin-3.18.6.ebuild 1551 BLAKE2B d034eacc21cb423a79ccd668d322d40f23aed57392d75aa75b10f3f90f634d96510e5e87c485b04bca566cfdc7bb59056f75a13493e90e92ad4ea13ffe4198f8 SHA512 6ed4f208ec25a1805ed377749d9232ed59f890eaedcdbc1f58fa6c2b41eb77ea52d8dad9f7beec5ad8b156eac22384956faddf458562febf7e20ed1b88bff356
MISC metadata.xml 334 BLAKE2B 8f1a0784c57af6204db98f443bdb09df2a6432674d711a5ecf577c20e29f04a030549ea19c6e04f51cd9a36e60a6da94bebafbfcc10d52da87109e59c32d42ee SHA512 105a5442ba05b94b2886f9075bd89268d4f2e0567ad69a637a1bd7d7d0eafdc280dfdb198aab5d72525300a9be0d4ad78f6bfe6398c896cc9de0f591651d102c
diff --git a/net-print/hplip-plugin/hplip-plugin-3.18.10.ebuild b/net-print/hplip-plugin/hplip-plugin-3.18.10.ebuild
new file mode 100644
index 000000000000..d598946893c6
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.18.10.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit udev unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+#SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_escl.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_makeself "hplip-${PV}-plugin.run"
+}
+
+src_install() {
+ local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ mkdir -p "${ED}/var/lib/hp/"
+ cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}