summaryrefslogtreecommitdiff
path: root/net-proxy/cntlm/cntlm-0.93_beta5-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-proxy/cntlm/cntlm-0.93_beta5-r3.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-proxy/cntlm/cntlm-0.93_beta5-r3.ebuild')
-rw-r--r--net-proxy/cntlm/cntlm-0.93_beta5-r3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-proxy/cntlm/cntlm-0.93_beta5-r3.ebuild b/net-proxy/cntlm/cntlm-0.93_beta5-r3.ebuild
new file mode 100644
index 000000000000..4c6879ddacc1
--- /dev/null
+++ b/net-proxy/cntlm/cntlm-0.93_beta5-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Cntlm is an NTLM/NTLMv2 authenticating HTTP proxy"
+HOMEPAGE="http://cntlm.sourceforge.net/"
+SRC_URI="http://ftp.awk.cz/pub/${P//_}.tar.gz"
+S="${WORKDIR}/${P//_}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ acct-group/cntlm
+ acct-user/cntlm
+"
+
+src_prepare() {
+ default
+ eapply -p0 "${FILESDIR}"/${P}-buildsystem.patch # 334647
+}
+
+src_configure() {
+ tc-export CC
+
+ econf
+
+ # Replace default config file path in Makefile
+ sed -e 's~SYSCONFDIR=/usr/local/etc~SYSCONFDIR=/etc~' -i "${S}"/Makefile || die
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ dobin cntlm
+ dodoc COPYRIGHT README VERSION doc/cntlm.conf
+ doman doc/cntlm.1
+ newinitd "${FILESDIR}"/cntlm.initd cntlm
+ newconfd "${FILESDIR}"/cntlm.confd cntlm
+ systemd_dounit "${FILESDIR}"/cntlm.service
+ insinto /etc
+ insopts -m0600
+ doins doc/cntlm.conf
+}