summaryrefslogtreecommitdiff
path: root/net-proxy/tinyproxy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /net-proxy/tinyproxy
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'net-proxy/tinyproxy')
-rw-r--r--net-proxy/tinyproxy/Manifest2
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.11.0_rc1.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/net-proxy/tinyproxy/Manifest b/net-proxy/tinyproxy/Manifest
index e368e0bb39c4..635e5fb38f34 100644
--- a/net-proxy/tinyproxy/Manifest
+++ b/net-proxy/tinyproxy/Manifest
@@ -3,5 +3,7 @@ AUX tinyproxy-1.10.0.service 181 BLAKE2B 1e5c14f607d0c54d215a6ffe5656bac288e48ca
AUX tinyproxy.service 172 BLAKE2B d2e6199bfee2bac52e08d4c5506131f19e2630ebe1d9ed12f71d575cef37454c229e9e08b1fc89d9e26052a1192913289ed3602d69686d6894eb68b8639e7a5a SHA512 4c4cd36a7e34d9ee27c05475b72d1b61f90592ccb44c9deb96a1375bb681b7901702f078ed24b7c633074c83e450275a4a66829f3b270f75fc786a50d1ef393f
AUX tinyproxy.tmpfiles.conf 48 BLAKE2B f2cd35878580eb198920f5db8493e3e266b4325160a9590a0b59bef1cf0577d0129bb636d99442cdb2154b444a8cdc1c6d01b4850b57df774be00338c61902e4 SHA512 24440cdaed0af6cbdb191acb1769e0a17871ef95e03e62a6621a413a2616e5d90d748d909bb5d18c029b25d7bf91485dbe46ee11e8703a1cb9008be470536715
DIST tinyproxy-1.10.0.tar.xz 176060 BLAKE2B 58f9b443c731de6b74d689a80ebd422d3b6f51f643546ee144b37fb3262725246f6a5fa1015267a94f192f8715eaf71ffc078ead75e6225a210f58ec28ee8fcf SHA512 8d82598c5f9c89bc672f4632139ac52696d5c7788963de51688a8aeb576c69004f8338fe1e1897bf704a21dfd25ab1effb092003b6afaa9a88c2b5d0608310f5
+DIST tinyproxy-1.11.0-rc1.tar.xz 176732 BLAKE2B a448c90b17a8d3256aec1dba4307e9bce87ac421a67486e4987afbf22e49041971138f09e98a4a775cc05071b73b4f1b34e652eb2c0992b2a5fa1861a0df26b2 SHA512 e1d05777072d178c66d1f007163bcb4b3a0b1dfdf460881daaf962b5f1c0d0213ec5403bf50c161d811f46c8b50a476cd534f535962ec01b70fbb955471c1af1
EBUILD tinyproxy-1.10.0-r1.ebuild 1653 BLAKE2B 30ee264b5f273c6a9902f2c9680acfe46fbddabe2e826d9255f4a9b9e210a08c37cd619e5b78a7b2d59a45e73685b7ac758dcce13d349a5c4788e2555d8bc2e2 SHA512 7c4606f12aa17a36dee5bcc4561f7fd0e5d104f646d1347f3de37abc9b7f8c788a3f0be6907b4fa58916cea4c2778851299396e9d1b2cd6c377a4690469ac2d8
+EBUILD tinyproxy-1.11.0_rc1.ebuild 1722 BLAKE2B 5bbb0718f57f8b690aa7f309f4ed23225e75613a1ff3bf831ca86d466ee0370a4e82874db0b85c41bf2200aa65b72e681c4808f29767dbae61eebde5268dfc76 SHA512 d1c350ece4642aed0ceaf1c449a4a286e701b030b03d546b3865d6d32fcd2468316a1c8eba2a74e604b6ec21bd53498f10148f00d5de71937f3e66ad1580ff13
MISC metadata.xml 562 BLAKE2B db41afc703d1338c10ef24e682a96b5a945bc80fd4a4e798fa7e74fdfbb9b1b8449a9126b8506e60524e733fc4810a1499e1320e565840798f8bea4722d46380 SHA512 ade2407ef37db41cef982bee16d02621813899fff1c4c3eaa00dd7517af254def7ecf08f508a1e873eaf5d2843df22154272bf58f84954e512614107d333805c
diff --git a/net-proxy/tinyproxy/tinyproxy-1.11.0_rc1.ebuild b/net-proxy/tinyproxy/tinyproxy-1.11.0_rc1.ebuild
new file mode 100644
index 000000000000..7c0e27a1928d
--- /dev/null
+++ b/net-proxy/tinyproxy/tinyproxy-1.11.0_rc1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd tmpfiles
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="A lightweight HTTP/SSL proxy"
+HOMEPAGE="https://github.com/tinyproxy/tinyproxy/"
+SRC_URI="https://github.com/tinyproxy/tinyproxy/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="test debug +filter-proxy reverse-proxy transparent-proxy
++upstream-proxy +xtinyproxy-header"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( xtinyproxy-header )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DEPEND="
+ acct-group/tinyproxy
+ acct-user/tinyproxy
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s|nobody|${PN}|g" \
+ etc/${PN}.conf.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable filter-proxy filter) \
+ $(use_enable reverse-proxy reverse) \
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable upstream-proxy upstream) \
+ $(use_enable xtinyproxy-header xtinyproxy) \
+ --localstatedir=/var
+}
+
+src_test() {
+ # The make check target does not run the test suite
+ emake test
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ diropts -m0775 -o ${PN} -g ${PN}
+ keepdir /var/log/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-1.10.0.initd tinyproxy
+ systemd_newunit "${FILESDIR}"/${PN}-1.10.0.service tinyproxy.service
+ dotmpfiles "${FILESDIR}"/${PN}.tmpfiles.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.tmpfiles.conf
+
+ elog "For filtering domains and URLs, enable filter option in the configuration"
+ elog "file and add them to the filter file (one domain or URL per line)."
+}