summaryrefslogtreecommitdiff
path: root/net-voip/yate/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /net-voip/yate/files
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'net-voip/yate/files')
-rw-r--r--net-voip/yate/files/yate-6.2.0-my_bool.patch21
-rw-r--r--net-voip/yate/files/yate-9999-dont-mess-with-cflags.patch14
2 files changed, 21 insertions, 14 deletions
diff --git a/net-voip/yate/files/yate-6.2.0-my_bool.patch b/net-voip/yate/files/yate-6.2.0-my_bool.patch
new file mode 100644
index 000000000000..a2ddb857f397
--- /dev/null
+++ b/net-voip/yate/files/yate-6.2.0-my_bool.patch
@@ -0,0 +1,21 @@
+--- yate.o/modules/server/mysqldb.cpp 2020-03-03 18:03:34.000000000 +0200
++++ yate/modules/server/mysqldb.cpp 2020-12-29 15:38:56.717897678 +0200
+@@ -22,6 +22,7 @@
+ #include <yatephone.h>
+
+ #include <stdio.h>
++#include <stdbool.h>
+ #include <mysql.h>
+
+ #ifndef CLIENT_MULTI_STATEMENTS
+@@ -508,8 +509,8 @@
+
+ #ifdef MYSQL_OPT_RECONNECT
+ // this option must be set after connect - bug in mysql client library
+- my_bool reconn = 1;
+- mysql_options(mySqlConn->m_conn,MYSQL_OPT_RECONNECT,(const char*)&reconn);
++ bool reconn = 1;
++ mysql_options(mySqlConn->m_conn,MYSQL_OPT_RECONNECT,&reconn);
+ #endif
+
+ #ifdef HAVE_MYSQL_SET_CHARSET
diff --git a/net-voip/yate/files/yate-9999-dont-mess-with-cflags.patch b/net-voip/yate/files/yate-9999-dont-mess-with-cflags.patch
deleted file mode 100644
index 1a2a98c24e9e..000000000000
--- a/net-voip/yate/files/yate-9999-dont-mess-with-cflags.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://build.opensuse.org/package/view_file/network:telephony/yate/dont-mess-with-cflags.patch?expand=1
-
-Index: yate/configure.ac
-===================================================================
---- yate.orig/configure.ac
-+++ yate/configure.ac
-@@ -1652,7 +1652,6 @@ fi
-
-
- INSTALL_D="install -D"
--CFLAGS=`echo "$CFLAGS" | sed 's/\(^\| \+\)-g[[0-9]]*//' | sed 's/[[[:space:]]]\{2,\}/ /g'`
- MODULE_CFLAGS="-fno-exceptions -fPIC $HAVE_GCC_FORMAT_CHECK $HAVE_BLOCK_RETURN"
- MODULE_CPPFLAGS="$HAVE_NO_OVERLOAD_VIRT_WARN $RTTI_OPT $MODULE_CFLAGS"
- MODULE_LDRELAX="-rdynamic -shared"