summaryrefslogtreecommitdiff
path: root/net-vpn/networkmanager-strongswan/networkmanager-strongswan-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-vpn/networkmanager-strongswan/networkmanager-strongswan-1.6.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-vpn/networkmanager-strongswan/networkmanager-strongswan-1.6.0.ebuild')
-rw-r--r--net-vpn/networkmanager-strongswan/networkmanager-strongswan-1.6.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-vpn/networkmanager-strongswan/networkmanager-strongswan-1.6.0.ebuild b/net-vpn/networkmanager-strongswan/networkmanager-strongswan-1.6.0.ebuild
new file mode 100644
index 000000000000..86e540e050db
--- /dev/null
+++ b/net-vpn/networkmanager-strongswan/networkmanager-strongswan-1.6.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="NetworkManager"
+MY_P="${P/networkmanager/${MY_PN}}"
+
+DESCRIPTION="NetworkManager StrongSwan plugin"
+HOMEPAGE="https://www.strongswan.org/"
+SRC_URI="https://download.strongswan.org/${MY_PN}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gtk4"
+
+RDEPEND="
+ app-crypt/libsecret
+ >=net-libs/libnma-1.1.0
+ net-misc/networkmanager
+ >=net-vpn/strongswan-5.8.3[networkmanager]
+ !gtk4? ( x11-libs/gtk+:3 )
+ gtk4? (
+ net-libs/libnma
+ gui-libs/gtk:4
+ )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ # Don't enable all warnings, as some are treated as errors and the compilation will fail
+ --disable-more-warnings
+ --disable-static
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}