summaryrefslogtreecommitdiff
path: root/net-vpn/openvpn/openvpn-2.4.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /net-vpn/openvpn/openvpn-2.4.6.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'net-vpn/openvpn/openvpn-2.4.6.ebuild')
-rw-r--r--net-vpn/openvpn/openvpn-2.4.6.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/net-vpn/openvpn/openvpn-2.4.6.ebuild b/net-vpn/openvpn/openvpn-2.4.6.ebuild
index 09a11b23f047..41badc7b0794 100644
--- a/net-vpn/openvpn/openvpn-2.4.6.ebuild
+++ b/net-vpn/openvpn/openvpn-2.4.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,6 @@ IUSE="down-root examples inotify iproute2 libressl lz4 +lzo mbedtls pam"
IUSE+=" pkcs11 +plugins selinux +ssl static systemd test userland_BSD"
REQUIRED_USE="static? ( !plugins !pkcs11 )
- mbedtls? ( ssl !libressl )
pkcs11? ( ssl )
!plugins? ( !pam !down-root )
inotify? ( plugins )"
@@ -31,8 +30,8 @@ CDEPEND="
pam? ( virtual/pam )
ssl? (
!mbedtls? (
- !libressl? ( >=dev-libs/openssl-0.9.8:* )
- libressl? ( dev-libs/libressl )
+ !libressl? ( >=dev-libs/openssl-0.9.8:0= )
+ libressl? ( dev-libs/libressl:0= )
)
mbedtls? ( net-libs/mbedtls )
)
@@ -72,9 +71,9 @@ src_configure() {
IFCONFIG=/bin/ifconfig \
ROUTE=/bin/route \
econf \
- $(usex mbedtls '--with-crypto-library=mbedtls' '') \
$(use_enable inotify async-push) \
$(use_enable ssl crypto) \
+ $(use_with ssl crypto-library $(usex mbedtls mbedtls openssl)) \
$(use_enable lz4) \
$(use_enable lzo) \
$(use_enable pkcs11) \