summaryrefslogtreecommitdiff
path: root/net-vpn/riseup-vpn/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /net-vpn/riseup-vpn/files
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'net-vpn/riseup-vpn/files')
-rw-r--r--net-vpn/riseup-vpn/files/riseup-vpn-respect-AR.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-vpn/riseup-vpn/files/riseup-vpn-respect-AR.patch b/net-vpn/riseup-vpn/files/riseup-vpn-respect-AR.patch
new file mode 100644
index 000000000000..431ab1376c65
--- /dev/null
+++ b/net-vpn/riseup-vpn/files/riseup-vpn-respect-AR.patch
@@ -0,0 +1,38 @@
+diff --git a/gui/build.sh b/gui/build.sh
+index 56e3d66..9e519a6 100755
+--- a/gui/build.sh
++++ b/gui/build.sh
+@@ -63,13 +63,13 @@ function buildGoLib {
+ if [ "$XBUILD" == "no" ]
+ then
+ echo "[+] Building Go library with standard Go compiler"
+- CGO_ENABLED=1 GOOS=$GOOS CC=$CC CGO_CFLAGS=$CGO_CFLAGS CGO_LDFLAGS=$CGO_LDFLAGS go build -buildmode=c-archive -o $TARGET_GOLIB $SOURCE_GOLIB
++ CGO_ENABLED=1 GOOS=$GOOS CC=$CC CGO_CFLAGS=$CGO_CFLAGS CGO_LDFLAGS=$CGO_LDFLAGS go build -buildmode=c-archive -ldflags="-extar=$AR -extld=$LD -extldflags=$LDFLAGS" -o $TARGET_GOLIB $SOURCE_GOLIB
+ fi
+ if [ "$XBUILD" == "$WIN64" ]
+ then
+ echo "[+] Building Go library with mxe"
+ echo "[+] Using cc:" $CC
+- CC=$CC CGO_ENABLED=1 GOOS=windows GOARCH=amd64 go build -buildmode=c-archive -o $TARGET_GOLIB $SOURCE_GOLIB
++ CC=$CC CGO_ENABLED=1 GOOS=windows GOARCH=amd64 go build -buildmode=c-archive -ldflags="-extar=$AR -extld=$LD -extldflags=$LDFLAGS" -o $TARGET_GOLIB $SOURCE_GOLIB
+ fi
+ }
+
+@@ -77,7 +77,7 @@ function buildQmake {
+ echo "[+] Now building Qml app with Qt qmake"
+ echo "[+] Using qmake in:" $QMAKE
+ mkdir -p $QTBUILD
+- $QMAKE -o "$QTBUILD/Makefile" CONFIG+=release VENDOR_PATH=${VENDOR_PATH} $PROJECT
++ $QMAKE -early QMAKE_CC=$CC QMAKE_CXX=$CXX QMAKE_LINK=$CXX -o "$QTBUILD/Makefile" CONFIG+=release VENDOR_PATH=${VENDOR_PATH} $PROJECT
+ #CONFIG=+force_debug_info CONFIG+=debug CONFIG+=debug_and_release
+ }
+
+@@ -115,7 +115,7 @@ function buildDefault {
+ buildQmake
+
+ make -C $QTBUILD clean
+- make -C $QTBUILD -j4 all
++ make -C $QTBUILD $MAKEFLAGS all
+
+ renameOutput
+ echo "[+] Done."