summaryrefslogtreecommitdiff
path: root/net-wireless/blueman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-01 00:07:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-01 00:07:06 +0100
commit1551fe56fd6ba43a94509cffc61b6bf854b7ac9f (patch)
treebe99b6ceb874878a108d68c641b476a2df076517 /net-wireless/blueman
parent0e2a727aba684f1a44cc0402a3f77d242140681b (diff)
gentoo auto-resync : 01:06:2024 - 00:07:06
Diffstat (limited to 'net-wireless/blueman')
-rw-r--r--net-wireless/blueman/Manifest2
-rw-r--r--net-wireless/blueman/blueman-2.4.2.ebuild150
2 files changed, 152 insertions, 0 deletions
diff --git a/net-wireless/blueman/Manifest b/net-wireless/blueman/Manifest
index 9a81ae45308d..52ef0ba8bf68 100644
--- a/net-wireless/blueman/Manifest
+++ b/net-wireless/blueman/Manifest
@@ -1,5 +1,7 @@
AUX 01-org.blueman.rules 432 BLAKE2B c81ec47bc68be911b44056e4f0f4dd4e2939d8d5db78fbca9f4ddceb7c8ed0108bff1bc12d83ebfa9ed67f8939fdd0aea712aec4ae964f10d84a4a6077479a37 SHA512 5cea5f5e9f43e9778dd671ecfdf59e79d740abf278cd9a7250efcf790f632d9ff6b08bf82dff96292c45c3424be9dc290bb39c3bf329c853e02e0ae3f7bb213b
DIST blueman-2.4.1.tar.xz 1540776 BLAKE2B 0d191d9c3af673b0b74ee6a5a3242312670229853f47ccc044cf7f1a091d6a0b677f1c818c76ca372f535d5527c26eeaf0588729694176461b5b2afbfca33391 SHA512 154ad7bece4f513d523d2fcefa8ea2b6bd8a2ac991c1b4b86d81b7d25107cad9cdd5cbd21d25145e944fa2731575f0fd023b40ab0a3a6ba408741fad314c6b37
+DIST blueman-2.4.2.tar.xz 1529804 BLAKE2B a10957db2721d308ea6cdd0351c94910d527023e146afee794f63d5997af9ab530abdff19c74f8a645c16ba8c84377b720318fba69f78deb5d0e268f653470af SHA512 d394147e2fcc097d4922bf7dcebd1d6fa386eacbfb08f332006eb377be7b8b6c8a725b1578b01894b386bc87daf3129c08c11755aca07166cd246a74eeb4ccac
EBUILD blueman-2.4.1.ebuild 2991 BLAKE2B b37f7d6e517252db2a1b538b83a92f58945d17a0fabc6948152d4451f63ca3bfe550dac6951e60448a62eec1569f17c3d9c53702f77f941db1355fc68a421426 SHA512 af6b454fac6fbcb21b9c71137fa4366180eb4ece413170afc3b396cc07573c96ee6825db0cb9af0c541bc67fc09b90cdb30ed9276448bb56638357cd4914f620
+EBUILD blueman-2.4.2.ebuild 2997 BLAKE2B 80bba4216c4429dbf5676ec6b93dd50193b52054df0d4a3f59e462a73274a7bb88e54fbd77a6b7cc053163642a89d65d2d034658dd52815889d8a2a4ec6f2b4c SHA512 4dbcbe0f66e1316a78f7384370a9613b166e0c6672f831464e47fa0de992cae8644b2da01775954188f3a0191a3893fb1c9945647fcffb7321d276433fd42c77
EBUILD blueman-9999.ebuild 2997 BLAKE2B 80bba4216c4429dbf5676ec6b93dd50193b52054df0d4a3f59e462a73274a7bb88e54fbd77a6b7cc053163642a89d65d2d034658dd52815889d8a2a4ec6f2b4c SHA512 4dbcbe0f66e1316a78f7384370a9613b166e0c6672f831464e47fa0de992cae8644b2da01775954188f3a0191a3893fb1c9945647fcffb7321d276433fd42c77
MISC metadata.xml 499 BLAKE2B 54e6fc4cc7b9922abf5a8bae572c282bded5bce21add03e418effeb5009ce7700a3fbede5f132638aa934b71b0898310e1b8315c48a76216045d56e53c7cf1dc SHA512 30e120ce07c4b4bfc278dfcfcad987bf878ed1ebc0ec92d859cf943270c439cdf717b5a9f01ee36399a64743c98aa73f9cd91db4fc85e0c0cf6b73c75d62a817
diff --git a/net-wireless/blueman/blueman-2.4.2.ebuild b/net-wireless/blueman/blueman-2.4.2.ebuild
new file mode 100644
index 000000000000..bec135aa318c
--- /dev/null
+++ b/net-wireless/blueman/blueman-2.4.2.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools distutils-r1 gnome2-utils linux-info systemd xdg-utils
+
+DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
+HOMEPAGE="https://github.com/blueman-project/blueman/"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
+else
+ SRC_URI="
+ https://github.com/blueman-project/blueman/releases/download/${PV/_/.}/${P/_/.}.tar.xz
+ "
+ S=${WORKDIR}/${P/_/.}
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+# icons are GPL-2
+# source files are mixed GPL-3+ and GPL-2+
+LICENSE="GPL-3+ GPL-2"
+SLOT="0"
+IUSE="network nls policykit pulseaudio"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ >=net-wireless/bluez-5:=
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ ')
+ sys-apps/dbus
+ x11-libs/gtk+:3[introspection,X]
+ x11-libs/libnotify[introspection]
+ || (
+ x11-themes/adwaita-icon-theme
+ x11-themes/faenza-icon-theme
+ x11-themes/mate-icon-theme
+ )
+ network? (
+ net-firewall/iptables
+ || (
+ sys-apps/net-tools
+ sys-apps/iproute2
+ )
+ || (
+ net-dns/dnsmasq
+ net-misc/dhcp
+ >=net-misc/networkmanager-0.8[introspection]
+ )
+ )
+ policykit? (
+ sys-auth/polkit
+ )
+ pulseaudio? (
+ || (
+ media-sound/pulseaudio-daemon[bluetooth]
+ media-video/pipewire[bluetooth]
+ <media-sound/pulseaudio-15.99.1[bluetooth]
+ )
+ )
+"
+
+pkg_pretend() {
+ if use network; then
+ local CONFIG_CHECK="
+ ~BRIDGE
+ ~IP_NF_IPTABLES
+ ~IP_NF_NAT
+ ~IP_NF_TARGET_MASQUERADE
+ "
+ check_extra_config
+ fi
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ if [[ ${PV} == 9999 ]]; then
+ eautoreconf
+ else
+ # remove this when upstream switches to automake with .pyc fix
+ eautomake
+ fi
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ local myconf=(
+ --disable-runtime-deps-check
+ --disable-static
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ --with-dhcp-config="/etc/dhcp/dhcpd.conf"
+ $(use_enable policykit polkit)
+ $(use_enable nls)
+ $(use_enable pulseaudio)
+ # thunar integration is a single data file with no extra deps
+ # so install it unconditionally
+ --enable-thunar-sendto
+ )
+ econf "${myconf[@]}"
+}
+
+python_compile() {
+ default
+}
+
+python_install() {
+ default
+
+ if use policykit; then
+ # Allow users in plugdev group to modify connections
+ insinto /usr/share/polkit-1/rules.d
+ doins "${FILESDIR}/01-org.blueman.rules"
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}