summaryrefslogtreecommitdiff
path: root/net-wireless/gr-specest/gr-specest-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /net-wireless/gr-specest/gr-specest-9999.ebuild
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'net-wireless/gr-specest/gr-specest-9999.ebuild')
-rw-r--r--net-wireless/gr-specest/gr-specest-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-wireless/gr-specest/gr-specest-9999.ebuild b/net-wireless/gr-specest/gr-specest-9999.ebuild
new file mode 100644
index 000000000000..12a9c520a90b
--- /dev/null
+++ b/net-wireless/gr-specest/gr-specest-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils git-r3 python-single-r1
+
+DESCRIPTION="A module adding spectral estimation routines to GNU Radio"
+HOMEPAGE="https://github.com/kit-cel/gr-specest"
+EGIT_REPO_URI="https://github.com/kit-cel/gr-specest.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=net-wireless/gnuradio-3.7.0:=[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_configure() {
+ mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake-utils_src_configure
+}