summaryrefslogtreecommitdiff
path: root/net-wireless/hostapd/hostapd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /net-wireless/hostapd/hostapd-9999.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'net-wireless/hostapd/hostapd-9999.ebuild')
-rw-r--r--net-wireless/hostapd/hostapd-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-wireless/hostapd/hostapd-9999.ebuild b/net-wireless/hostapd/hostapd-9999.ebuild
index 6ab779890926..06ae239217e1 100644
--- a/net-wireless/hostapd/hostapd-9999.ebuild
+++ b/net-wireless/hostapd/hostapd-9999.ebuild
@@ -26,7 +26,10 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="internal-tls ipv6 libressl logwatch netlink sqlite +wps +crda"
+IUSE="internal-tls ipv6 libressl logwatch netlink sqlite +suiteb +wps +crda"
+
+# suiteb impl uses openssl feature not available in libressl, see bug 710992
+REQUIRED_USE="?? ( libressl suiteb )"
DEPEND="
libressl? ( dev-libs/libressl:0= )
@@ -93,8 +96,11 @@ src_configure() {
echo "CONFIG_SAE=y" >> ${CONFIG}
echo "CONFIG_OWE=y" >> ${CONFIG}
echo "CONFIG_DPP=y" >> ${CONFIG}
- echo "CONFIG_SUITEB=y" >> ${CONFIG}
- echo "CONFIG_SUITEB192=y" >> ${CONFIG}
+
+ if use suiteb; then
+ echo "CONFIG_SUITEB=y" >> ${CONFIG}
+ echo "CONFIG_SUITEB192=y" >> ${CONFIG}
+ fi
if use internal-tls && ! use libressl; then
echo "CONFIG_TLS=internal" >> ${CONFIG}