summaryrefslogtreecommitdiff
path: root/net-wireless/osmo-fl2k/osmo-fl2k-0.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-21 01:50:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-21 01:50:31 +0000
commit2ac4d6eef70b0af1c7380b190dd14c8df8a4b9a5 (patch)
tree99640217df95ed54255127d0f54f43d19474348f /net-wireless/osmo-fl2k/osmo-fl2k-0.2.0.ebuild
parent1fb8608d6f0b1acf0e34361c105533087a09c710 (diff)
gentoo auto-resync : 21:12:2023 - 01:50:31
Diffstat (limited to 'net-wireless/osmo-fl2k/osmo-fl2k-0.2.0.ebuild')
-rw-r--r--net-wireless/osmo-fl2k/osmo-fl2k-0.2.0.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-wireless/osmo-fl2k/osmo-fl2k-0.2.0.ebuild b/net-wireless/osmo-fl2k/osmo-fl2k-0.2.0.ebuild
new file mode 100644
index 000000000000..4f95c0da4bf9
--- /dev/null
+++ b/net-wireless/osmo-fl2k/osmo-fl2k-0.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic linux-info udev
+
+DESCRIPTION="turns FL2000-based USB 3.0 to VGA adapters into low cost DACs"
+HOMEPAGE="https://osmocom.org/projects/osmo-fl2k/wiki"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitea.osmocom.org/sdr/osmo-fl2k"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://gitea.osmocom.org/sdr/osmo-fl2k/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+IUSE="udev"
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}
+ media-sound/sox
+ sys-apps/pv"
+
+# continguous memory allocator can optionally be used for zero-copy transfer
+# TODO: tell users to set CONFIG_CMA_SIZE_MBYTES or boot with cma=... parameter
+CONFIG_CHECK="~CMA ~DMA_CMA"
+
+src_configure() {
+ # udev rules use wrong filename and would go to wrong directory anyway
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="/usr/$(get_libdir)"
+ -DINSTALL_UDEV_RULES=OFF
+ )
+ #https://gcc.gnu.org/bugzilla/show_bug.cgi?id=49653
+ replace-flags -O0 -O2
+ replace-flags -Os -O2
+ cmake_src_configure
+}
+
+src_install() {
+ if use udev; then
+ udev_newrules ${PN}.rules 99-${PN}.rules
+ fi
+ cmake_src_install
+ # https://bugs.gentoo.org/727984
+ # No obvious way to prevent build
+ find "${ED}" -name libosmo-fl2k.a -delete
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}