summaryrefslogtreecommitdiff
path: root/net-wireless/rfkill/rfkill-0.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /net-wireless/rfkill/rfkill-0.5-r2.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'net-wireless/rfkill/rfkill-0.5-r2.ebuild')
-rw-r--r--net-wireless/rfkill/rfkill-0.5-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-wireless/rfkill/rfkill-0.5-r2.ebuild b/net-wireless/rfkill/rfkill-0.5-r2.ebuild
new file mode 100644
index 000000000000..ab6b3fa74faf
--- /dev/null
+++ b/net-wireless/rfkill/rfkill-0.5-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to read and control rfkill status through /dev/rfkill"
+HOMEPAGE="https://wireless.kernel.org/en/users/Documentation/rfkill"
+SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="!>=sys-apps/util-linux-2.31_rc1"
+DEPEND=""
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getLD) V=1 || die "Failed to compile"
+}
+
+src_install() {
+ emake install V=1 DESTDIR="${D}" || die "Failed to install"
+}