summaryrefslogtreecommitdiff
path: root/net-wireless/rfkill/rfkill-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /net-wireless/rfkill/rfkill-1.0.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'net-wireless/rfkill/rfkill-1.0.ebuild')
-rw-r--r--net-wireless/rfkill/rfkill-1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-wireless/rfkill/rfkill-1.0.ebuild b/net-wireless/rfkill/rfkill-1.0.ebuild
new file mode 100644
index 000000000000..2dcc85799b0b
--- /dev/null
+++ b/net-wireless/rfkill/rfkill-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to read and control rfkill status through /dev/rfkill"
+HOMEPAGE="https://wireless.kernel.org/en/users/Documentation/rfkill"
+SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="!>=sys-apps/util-linux-2.31_rc1"
+DEPEND=""
+
+src_prepare() {
+ sed -i 's#rfkill.8.gz#rfkill.8#' Makefile
+ default
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getLD) V=1
+}
+
+src_install() {
+ emake install V=1 DESTDIR="${D}"
+}