summaryrefslogtreecommitdiff
path: root/net-wireless/uhd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /net-wireless/uhd/files
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'net-wireless/uhd/files')
-rw-r--r--net-wireless/uhd/files/uhd-3.10.3.0-tinfo.patch34
-rw-r--r--net-wireless/uhd/files/uhd-3.8.5-gcc6.patch25
-rw-r--r--net-wireless/uhd/files/uhd-3.9.6-tinfo.patch34
3 files changed, 68 insertions, 25 deletions
diff --git a/net-wireless/uhd/files/uhd-3.10.3.0-tinfo.patch b/net-wireless/uhd/files/uhd-3.10.3.0-tinfo.patch
new file mode 100644
index 000000000000..ff9956fee41c
--- /dev/null
+++ b/net-wireless/uhd/files/uhd-3.10.3.0-tinfo.patch
@@ -0,0 +1,34 @@
+--- host/utils/latency/CMakeLists.txt.orig 2017-05-11 19:44:54.824946672 +0300
++++ host/utils/latency/CMakeLists.txt 2017-05-11 19:45:08.498880360 +0300
+@@ -35,7 +35,8 @@
+ GET_FILENAME_COMPONENT(name ${source} NAME_WE)
+ ADD_EXECUTABLE(${name} ${source} ${latency_lib_path})
+ LIBUHD_APPEND_SOURCES(${name})
+- TARGET_LINK_LIBRARIES(${name} uhd ${Boost_LIBRARIES} ${CURSES_LIBRARIES})
++ TARGET_LINK_LIBRARIES(${name} uhd ${Boost_LIBRARIES}
++ ${CURSES_LIBRARIES} tinfo)
+ UHD_INSTALL(TARGETS ${name} RUNTIME DESTINATION ${latency_comp_dest} COMPONENT ${latency_comp_name})
+ ENDFOREACH(source)
+
+--- host/examples/CMakeLists.txt.orig 2017-05-11 19:41:02.322302577 +0300
++++ host/examples/CMakeLists.txt 2017-05-11 19:44:32.604066325 +0300
+@@ -59,7 +59,7 @@
+ IF(CURSES_FOUND)
+ INCLUDE_DIRECTORIES(${CURSES_INCLUDE_DIR})
+ ADD_EXECUTABLE(rx_ascii_art_dft rx_ascii_art_dft.cpp)
+- TARGET_LINK_LIBRARIES(rx_ascii_art_dft uhd ${CURSES_LIBRARIES} ${Boost_LIBRARIES})
++ TARGET_LINK_LIBRARIES(rx_ascii_art_dft uhd ${CURSES_LIBRARIES} tinfo ${Boost_LIBRARIES})
+ UHD_INSTALL(TARGETS rx_ascii_art_dft RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
+ ENDIF(CURSES_FOUND)
+
+--- host/CMakeLists.txt.orig 2017-05-11 19:36:38.944798634 +0300
++++ host/CMakeLists.txt 2017-05-11 19:36:40.819788408 +0300
+@@ -436,6 +436,8 @@
+ LIST(APPEND UHD_LINK_LIST_STATIC "usb-1.0")
+ ENDIF(ENABLE_USB)
+
++LIST(APPEND UHD_LINK_LIST_STATIC "tinfo")
++
+ CONFIGURE_FILE(
+ ${CMAKE_SOURCE_DIR}/cmake/Modules/UHDConfigVersion.cmake.in
+ ${CMAKE_BINARY_DIR}/cmake/Modules/UHDConfigVersion.cmake
diff --git a/net-wireless/uhd/files/uhd-3.8.5-gcc6.patch b/net-wireless/uhd/files/uhd-3.8.5-gcc6.patch
deleted file mode 100644
index c2e5e00f70d6..000000000000
--- a/net-wireless/uhd/files/uhd-3.8.5-gcc6.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Bug: https://bugs.gentoo.org/611680
-Backported from: https://github.com/EttusResearch/uhd/commit/b6ad4c0531ef56f4e197cccd06f1d11fc89e4aab
-
---- a/host/lib/usrp/dboard/db_cbx.cpp
-+++ b/host/lib/usrp/dboard/db_cbx.cpp
-@@ -38,7 +38,7 @@ sbx_xcvr::cbx::~cbx(void){
- /* NOP */
- }
-
--void sbx_xcvr::cbx::write_lo_regs(dboard_iface::unit_t unit, std::vector<boost::uint32_t> &regs)
-+void sbx_xcvr::cbx::write_lo_regs(dboard_iface::unit_t unit, const std::vector<boost::uint32_t> &regs)
- {
- BOOST_FOREACH(boost::uint32_t reg, regs)
- {
---- a/host/lib/usrp/dboard/db_sbx_common.hpp
-+++ b/host/lib/usrp/dboard/db_sbx_common.hpp
-@@ -225,7 +225,7 @@ class sbx_xcvr : public xcvr_dboard_base{
- /*! This is the registered instance of the wrapper class, sbx_base. */
- sbx_xcvr *self_base;
- private:
-- void write_lo_regs(dboard_iface::unit_t unit, std::vector<boost::uint32_t> &regs);
-+ void write_lo_regs(dboard_iface::unit_t unit, const std::vector<boost::uint32_t> &regs);
- max287x_iface::sptr _txlo;
- max287x_iface::sptr _rxlo;
- };
diff --git a/net-wireless/uhd/files/uhd-3.9.6-tinfo.patch b/net-wireless/uhd/files/uhd-3.9.6-tinfo.patch
new file mode 100644
index 000000000000..511bc3c13fcd
--- /dev/null
+++ b/net-wireless/uhd/files/uhd-3.9.6-tinfo.patch
@@ -0,0 +1,34 @@
+--- uhd-release_003_009_006/host/utils/latency/CMakeLists.txt.orig 2017-05-11 19:44:54.824946672 +0300
++++ uhd-release_003_009_006/host/utils/latency/CMakeLists.txt 2017-05-11 19:45:08.498880360 +0300
+@@ -35,7 +35,8 @@
+ GET_FILENAME_COMPONENT(name ${source} NAME_WE)
+ ADD_EXECUTABLE(${name} ${source} ${latency_lib_path})
+ LIBUHD_APPEND_SOURCES(${name})
+- TARGET_LINK_LIBRARIES(${name} uhd ${Boost_LIBRARIES} ${CURSES_LIBRARIES})
++ TARGET_LINK_LIBRARIES(${name} uhd ${Boost_LIBRARIES}
++ ${CURSES_LIBRARIES} tinfo)
+ UHD_INSTALL(TARGETS ${name} RUNTIME DESTINATION ${latency_comp_dest} COMPONENT ${latency_comp_name})
+ ENDFOREACH(source)
+
+--- uhd-release_003_009_006/host/examples/CMakeLists.txt.orig 2017-05-11 19:41:02.322302577 +0300
++++ uhd-release_003_009_006/host/examples/CMakeLists.txt 2017-05-11 19:44:32.604066325 +0300
+@@ -59,7 +59,7 @@
+ IF(CURSES_FOUND)
+ INCLUDE_DIRECTORIES(${CURSES_INCLUDE_DIR})
+ ADD_EXECUTABLE(rx_ascii_art_dft rx_ascii_art_dft.cpp)
+- TARGET_LINK_LIBRARIES(rx_ascii_art_dft uhd ${CURSES_LIBRARIES} ${Boost_LIBRARIES})
++ TARGET_LINK_LIBRARIES(rx_ascii_art_dft uhd ${CURSES_LIBRARIES} tinfo ${Boost_LIBRARIES})
+ UHD_INSTALL(TARGETS rx_ascii_art_dft RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
+ ENDIF(CURSES_FOUND)
+
+--- uhd-release_003_009_006/host/CMakeLists.txt.orig 2017-05-11 19:36:38.944798634 +0300
++++ uhd-release_003_009_006/host/CMakeLists.txt 2017-05-11 19:36:40.819788408 +0300
+@@ -436,6 +436,8 @@
+ LIST(APPEND UHD_LINK_LIST_STATIC "usb-1.0")
+ ENDIF(ENABLE_USB)
+
++LIST(APPEND UHD_LINK_LIST_STATIC "tinfo")
++
+ CONFIGURE_FILE(
+ ${CMAKE_SOURCE_DIR}/cmake/Modules/UHDConfigVersion.cmake.in
+ ${CMAKE_BINARY_DIR}/cmake/Modules/UHDConfigVersion.cmake