summaryrefslogtreecommitdiff
path: root/profiles/features/prefix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /profiles/features/prefix
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'profiles/features/prefix')
-rw-r--r--profiles/features/prefix/standalone/kernel-2.6.16+/make.defaults7
-rw-r--r--profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc18
2 files changed, 20 insertions, 5 deletions
diff --git a/profiles/features/prefix/standalone/kernel-2.6.16+/make.defaults b/profiles/features/prefix/standalone/kernel-2.6.16+/make.defaults
index c64a419f389d..e8e0ce1eaeac 100644
--- a/profiles/features/prefix/standalone/kernel-2.6.16+/make.defaults
+++ b/profiles/features/prefix/standalone/kernel-2.6.16+/make.defaults
@@ -9,9 +9,14 @@
# utimensat is missing or not reliable until linux-2.6.32.
# needed by python-3.
+# lutimes requires utimensat
ac_cv_func_utimensat=no
-# pipe2 requires >=linux-2.6.27. Needed by python-3.
+ac_cv_func_lutimes=no
+# pipe2 and dup3 requires >=linux-2.6.27. Needed by python-3.
ac_cv_func_pipe2=no
+ac_cv_func_dup3=no
+# epoll_create1 requires >=linux-2.6.27.
+ac_cv_func_epoll_create1=no
# >=python-3 is masked.
PYTHON_TARGETS=python2_7
diff --git a/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc b/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
index eeba17808ece..c08217181df4 100644
--- a/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
+++ b/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
@@ -2,15 +2,25 @@
if [[ ${CATEGORY}/${PN} == dev-util/cmake && ${EBUILD_PHASE} == configure ]]; then
einfo "Removing utimensat outputs..."
- sed -e '/UTIMENSAT=/d' -i ${S}/Source/kwsys/CMakeLists.txt || die
+ sed -e '/UTIMENSAT=/d' -i "${S}"/Source/kwsys/CMakeLists.txt || die
elif [[ ${CATEGORY}/${PN} == dev-qt/qtcore && ${EBUILD_PHASE} == configure ]]; then
einfo "Removing pipe2 definitions..."
- sed -e '/define.*HAVE_PIPE2/d' -i ${S}/src/3rdparty/forkfd/forkfd.c || die
+ sed -e '/define.*HAVE_PIPE2/d' -i "${S}"/src/3rdparty/forkfd/forkfd.c || die
einfo "Removing utimensat calls..."
- sed -e '/_POSIX_VERSION/s/defined(_POSIX_VERSION)/0/' -i ${S}/qmake/library/ioutils.cpp || die
+ sed -e '/_POSIX_VERSION/s/defined(_POSIX_VERSION)/0/' -i "${S}"/qmake/library/ioutils.cpp || die
elif [[ ${CATEGORY}/${PN} == dev-lang/ocaml && ${EBUILD_PHASE} == configure ]]; then
einfo "Removing dup3 and pipe2 definitions..."
- sed -e '/hasgot dup3/,/^fi/d;/hasgot pipe2/,/^fi/d' -i ${S}/configure || die
+ sed -e '/hasgot dup3/,/^fi/d;/hasgot pipe2/,/^fi/d' -i "${S}"/configure || die
+elif [[ ${CATEGORY}/${PN} == sys-libs/glibc && ${EBUILD_PHASE} == compile ]]; then
+ einfo "Removing F_DUPFD_CLOEXEC definitions..."
+ sed -e '/define.*F_DUPFD_CLOEXEC/,/*\//d' -i "${S}"/sysdeps/unix/sysv/linux/bits/fcntl-linux.h || die
+ einfo "Removing pipe2 definitions..."
+ sed -e '/^extern int pipe2/d' -i "${S}"/posix/unistd.h || die
+ einfo "Removing epoll_create1 definitions..."
+ sed -e '/^extern int epoll_create1/d' -i "${S}"/sysdeps/unix/sysv/linux/sys/epoll.h || die
+ einfo "Removing lutimes and utimensat definitions..."
+ sed -e '/^extern int lutimes/,/__THROW/d' -i "${S}"/time/sys/time.h || die
+ sed -e '/^extern int utimensat/,/__THROW/d' -i "${S}"/io/sys/stat.h || die
fi
# Local Variables: