summaryrefslogtreecommitdiff
path: root/ros-meta/bond_core/bond_core-1.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /ros-meta/bond_core/bond_core-1.8.2.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'ros-meta/bond_core/bond_core-1.8.2.ebuild')
-rw-r--r--ros-meta/bond_core/bond_core-1.8.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/ros-meta/bond_core/bond_core-1.8.2.ebuild b/ros-meta/bond_core/bond_core-1.8.2.ebuild
new file mode 100644
index 000000000000..3e7d9f2c2f8e
--- /dev/null
+++ b/ros-meta/bond_core/bond_core-1.8.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A bond allows two processes, A and B, to know when the other has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bond
+ dev-ros/bondcpp
+ dev-ros/bondpy
+ dev-ros/smclib
+ dev-ros/test_bond
+"
+DEPEND="${RDEPEND}"