summaryrefslogtreecommitdiff
path: root/ros-meta/diagnostics/diagnostics-1.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /ros-meta/diagnostics/diagnostics-1.11.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'ros-meta/diagnostics/diagnostics-1.11.0.ebuild')
-rw-r--r--ros-meta/diagnostics/diagnostics-1.11.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/ros-meta/diagnostics/diagnostics-1.11.0.ebuild b/ros-meta/diagnostics/diagnostics-1.11.0.ebuild
new file mode 100644
index 000000000000..0eec07973448
--- /dev/null
+++ b/ros-meta/diagnostics/diagnostics-1.11.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Packages related to gathering, viewing, and analyzing diagnostics data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_aggregator
+ dev-ros/diagnostic_analysis
+ dev-ros/diagnostic_common_diagnostics
+ dev-ros/diagnostic_updater
+ dev-ros/rosdiagnostic
+ dev-ros/self_test
+ dev-ros/test_diagnostic_aggregator
+"
+DEPEND="${RDEPEND}"