summaryrefslogtreecommitdiff
path: root/ros-meta/qt_gui_core/qt_gui_core-0.3.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /ros-meta/qt_gui_core/qt_gui_core-0.3.16.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'ros-meta/qt_gui_core/qt_gui_core-0.3.16.ebuild')
-rw-r--r--ros-meta/qt_gui_core/qt_gui_core-0.3.16.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/ros-meta/qt_gui_core/qt_gui_core-0.3.16.ebuild b/ros-meta/qt_gui_core/qt_gui_core-0.3.16.ebuild
new file mode 100644
index 000000000000..d46ab876852d
--- /dev/null
+++ b/ros-meta/qt_gui_core/qt_gui_core-0.3.16.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Integration of the ROS package system and ROS-specific plugins for a Qt-based GUI"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/qt_dotgraph
+ dev-ros/qt_gui
+ dev-ros/qt_gui_app
+ dev-ros/qt_gui_cpp
+ dev-ros/qt_gui_py_common
+"
+DEPEND="${RDEPEND}"