summaryrefslogtreecommitdiff
path: root/sci-astronomy/pal/pal-0.9.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-astronomy/pal/pal-0.9.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-astronomy/pal/pal-0.9.7.ebuild')
-rw-r--r--sci-astronomy/pal/pal-0.9.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-astronomy/pal/pal-0.9.7.ebuild b/sci-astronomy/pal/pal-0.9.7.ebuild
new file mode 100644
index 000000000000..c165f47d600a
--- /dev/null
+++ b/sci-astronomy/pal/pal-0.9.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Positional Astronomy Library"
+HOMEPAGE="https://github.com/Starlink/pal"
+SRC_URI="https://github.com/Starlink/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+RDEPEND="sci-astronomy/erfa:="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --without-starlink \
+ --without-stardocs \
+ --with-erfa \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ # remove cruft from non-fhs complient
+ rm -r "${ED}"usr/share/pal || die
+ rm -r "${ED}"usr/{docs,manifests,news} || die
+ use static-libs || prune_libtool_files --all
+}