summaryrefslogtreecommitdiff
path: root/sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild')
-rw-r--r--sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild64
1 files changed, 34 insertions, 30 deletions
diff --git a/sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild b/sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild
index 834a57a2649c..784c9d8c33fe 100644
--- a/sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild
+++ b/sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
AUTOTOOLS_AUTO_DEPEND=no
@@ -10,65 +10,69 @@ inherit autotools
DESCRIPTION="Extract catalogs of sources from astronomical FITS images"
HOMEPAGE="http://www.astromatic.net/software/sextractor"
SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-3"
SLOT="0"
-
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc modelfit test threads"
+REQUIRED_USE="test? ( modelfit )"
RESTRICT="!test? ( test )"
RDEPEND="
!games-misc/sex
- modelfit? ( sci-libs/atlas[lapack,threads=] sci-libs/fftw:3.0 )"
+ modelfit? (
+ sci-libs/atlas[lapack,threads=]
+ sci-libs/fftw:3.0=
+ )"
DEPEND="${RDEPEND}
modelfit? ( ${AUTOTOOLS_DEPEND} )"
-REQUIRED_USE="test? ( modelfit )"
-
PATCHES=(
- "${FILESDIR}/${P}-fix-format-errors.patch"
- "${FILESDIR}/${P}-have-malloc.patch"
- "${FILESDIR}/${P}-have-mmap.patch"
- "${FILESDIR}/${P}-sigbus.patch"
+ "${FILESDIR}"/${P}-fix-format-errors.patch
+ "${FILESDIR}"/${P}-have-malloc.patch
+ "${FILESDIR}"/${P}-have-mmap.patch
+ "${FILESDIR}"/${P}-sigbus.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_prepare() {
default
+
if use modelfit; then
- local mycblas=atlcblas myclapack=atlclapack
- if use threads; then
- [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptcblas.so ]] && \
- mycblas=ptcblas
- [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptclapack.so ]] && \
- myclapack=ptclapack
- fi
- sed -i \
- -e "s/-lcblas/-l${mycblas}/g" \
- -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
- -e "s/-llapack/-l${myclapack}/g" \
- -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
- acx_atlas.m4 || die
- eautoreconf
+ local mycblas=atlcblas
+ local myclapack=atlclapack
+ if use threads; then
+ [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptcblas.so ]] && \
+ mycblas=ptcblas
+ [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptclapack.so ]] && \
+ myclapack=ptclapack
+ fi
+ sed -i \
+ -e "s/-lcblas/-l${mycblas}/g" \
+ -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
+ -e "s/-llapack/-l${myclapack}/g" \
+ -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
+ acx_atlas.m4 || die
+ eautoreconf
fi
}
src_configure() {
econf \
- --with-atlas-incdir="${EPREFIX}/usr/include/atlas" \
+ --with-atlas-incdir="${EPREFIX}"/usr/include/atlas \
$(use_enable modelfit model-fitting) \
$(use_enable threads)
}
src_install() {
default
- CONFDIR=/usr/share/sextractor
- insinto ${CONFDIR}
- doins config/*
- use doc && dodoc doc/*
+
+ insinto /usr/share/sextractor
+ doins -r config/.
+ use doc && dodoc -r doc/.
}
pkg_postinst() {
elog "SExtractor examples configuration files are located in"
- elog "${EROOT%/}/${CONFDIR} and are not loaded anymore by default."
+ elog "${EROOT}/usr/share/sextractor and are not loaded anymore by default."
}