summaryrefslogtreecommitdiff
path: root/sci-astronomy/sirilic/sirilic-1.14.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-astronomy/sirilic/sirilic-1.14.3.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-astronomy/sirilic/sirilic-1.14.3.ebuild')
-rw-r--r--sci-astronomy/sirilic/sirilic-1.14.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sci-astronomy/sirilic/sirilic-1.14.3.ebuild b/sci-astronomy/sirilic/sirilic-1.14.3.ebuild
new file mode 100644
index 000000000000..9a431ab22e09
--- /dev/null
+++ b/sci-astronomy/sirilic/sirilic-1.14.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Preparing acquisition files for processing with the SiriL software"
+HOMEPAGE="https://gitlab.com/free-astro/sirilic"
+SRC_URI="https://gitlab.com/free-astro/sirilic/-/archive/V${PV//./_}/${PN}-V${PV//./_}.tar.bz2"
+S="${WORKDIR}/${PN}-V${PV//./_}"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/wxpython:4.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"