summaryrefslogtreecommitdiff
path: root/sci-biology/cutg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-biology/cutg
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-biology/cutg')
-rw-r--r--sci-biology/cutg/Manifest2
-rw-r--r--sci-biology/cutg/cutg-160-r1.ebuild33
2 files changed, 14 insertions, 21 deletions
diff --git a/sci-biology/cutg/Manifest b/sci-biology/cutg/Manifest
index 8adcb37009e2..dad1300c3563 100644
--- a/sci-biology/cutg/Manifest
+++ b/sci-biology/cutg/Manifest
@@ -1,3 +1,3 @@
DIST cutg-160.tar.xz 178015420 BLAKE2B acfc65f4f152b7293cb8ec8e2bfa3c2c33c5da7bcdcae5349d13122e36c4061931195034548963cb78f6350bce88f72e4fc764f119e181f1f6278ee837b65b6e SHA512 9b72283f311fb805b7b22f59f3ca8fed2ab0af72b82247900922999792c1b112dcaca9b29b265a1e0e7b9eaf9ff846a1dc4c196fb95ddbfb3ee5175755ffb8e7
-EBUILD cutg-160-r1.ebuild 1250 BLAKE2B d973e58297166a5200efa01d08cc1053d6932e44e686b57d8135914fe53e23e6a336e4cf1b851f3c587e6a39087ae9bfb6a24e5e539f3a8892d6a8248a85a927 SHA512 4b7e71b255def1ece36d75ac85aa39e82b9e224317631801731fa0621e4841b00f6aa830e1fc43bb7e74fb387a2663c3848d9e0a5f99f550778448ab571ccacf
+EBUILD cutg-160-r1.ebuild 1013 BLAKE2B b60896afcc643f6c0d79361839b004e641f648fdbd48ee1e697a4f6a2b4197f7dd3e752561c7e050bbfc4bd0e7577b1af04c1518bf70015e25a4b502845f602f SHA512 38fc329c36da76f23593ab61bb5a0d09d7018044d398cc014462a63e333b8437e447988acbc091afedea50386f70c9b6948deff1090855c7be74bd97c8956dff
MISC metadata.xml 601 BLAKE2B 57d7aecf5afa8d6254de9ac825e0792bcefea19b962204c62c98938d60e2aec4045dcf289b0eebfb36d8a97ddbc91f80e3329a4a87edd0659cd6afc3c976318a SHA512 ed9ad9f404db1bf7e0a1550c139f9486135313a21796d52fb468dc00557228de9433eb1bedc363e5e932eb460be696a22e4ac6fbbed0c877094ebebe13b294c0
diff --git a/sci-biology/cutg/cutg-160-r1.ebuild b/sci-biology/cutg/cutg-160-r1.ebuild
index 9a8130969019..97abacaab1e4 100644
--- a/sci-biology/cutg/cutg-160-r1.ebuild
+++ b/sci-biology/cutg/cutg-160-r1.ebuild
@@ -1,49 +1,42 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
DESCRIPTION="Codon usage tables calculated from GenBank"
HOMEPAGE="http://www.kazusa.or.jp/codon/"
SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
-SLOT="0"
LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
# Minimal build keeps only the indexed files (if applicable) and the
# documentation. The non-indexed database is not installed.
IUSE="emboss minimal"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-DEPEND="emboss? ( sci-biology/emboss )"
-RDEPEND="${DEPEND}"
-
RESTRICT="binchecks strip"
+RDEPEND="emboss? ( sci-biology/emboss )"
+BDEPEND="${RDEPEND}"
+
src_compile() {
if use emboss; then
mkdir CODONS || die
ebegin "Indexing CUTG for usage with EMBOSS."
- EMBOSS_DATA="." cutgextract -auto -directory "${S}" || die \
- "Indexing CUTG failed."
+ EMBOSS_DATA="." cutgextract -auto -directory "${S}" || die "Indexing CUTG failed"
eend
fi
}
src_install() {
- local file
dodoc README CODON_LABEL SPSUM_LABEL
+
if ! use minimal; then
- dodir /usr/share/${PN}
- mv *.codon *.spsum "${ED}"/usr/share/${PN} || die \
- "Installing raw CUTG database failed."
+ insinto /usr/share/cutg
+ doins *.codon *.spsum
fi
if use emboss; then
- dodir /usr/share/EMBOSS/data/CODONS
- cd CODONS || die
- for file in *; do
- mv ${file} "${ED}"/usr/share/EMBOSS/data/CODONS/ || die \
- "Installing the EMBOSS-indexed database failed."
- done
+ insinto /usr/share/EMBOSS/data
+ doins -r CODONS
fi
}