summaryrefslogtreecommitdiff
path: root/sci-biology/eugene/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /sci-biology/eugene/files
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'sci-biology/eugene/files')
-rw-r--r--sci-biology/eugene/files/eugene-3.6-plugins.patch58
-rw-r--r--sci-biology/eugene/files/eugene-4.1d-portable-getopt.patch74
2 files changed, 108 insertions, 24 deletions
diff --git a/sci-biology/eugene/files/eugene-3.6-plugins.patch b/sci-biology/eugene/files/eugene-3.6-plugins.patch
index 1e910a13d5b1..e7424f73fc63 100644
--- a/sci-biology/eugene/files/eugene-3.6-plugins.patch
+++ b/sci-biology/eugene/files/eugene-3.6-plugins.patch
@@ -1,7 +1,36 @@
-http://bugs.gentoo.org/show_bug.cgi?id=297536
+https://bugs.gentoo.org/297536
---- eugene-3.6/src/Makefile.am
-+++ eugene-3.6/src/Makefile.am
+--- a/configure.ac
++++ b/configure.ac
+@@ -28,6 +28,7 @@
+ AC_PROG_CC
+ AC_PROG_AWK
+ AC_PROG_LN_S
++AM_PROG_AR
+ AC_PROG_RANLIB
+
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -137,7 +137,7 @@
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Style
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Javascripts
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Images
+- $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/plugins
++ $(INSTALL) -d $(DESTDIR)/$(libdir)/eugene/plugins
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/cfg
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/models
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/models/WAM
+@@ -160,6 +160,6 @@
+ $(INSTALL) -m 644 $(srcdir)/web/Images/*jpg $(DESTDIR)/$(pkgdatadir)/web/Images
+ $(INSTALL) -m 644 $(srcdir)/cfg/*.obo $(DESTDIR)/$(pkgdatadir)/cfg
+ $(INSTALL) -m 644 $(srcdir)/cfg/*.par $(DESTDIR)/$(pkgdatadir)/cfg
+- $(INSTALL) src/SensorPlugins/*/*.so $(DESTDIR)/$(pkgdatadir)/plugins
++ $(INSTALL) src/SensorPlugins/*/*.so $(DESTDIR)/$(libdir)/eugene/plugins
+ $(INSTALL) $(srcdir)/Procedures/Eval/egn_* $(DESTDIR)/$(pkgdatadir)/Procedures/Eval
+ $(INSTALL) $(srcdir)/Procedures/Get/egn_* $(DESTDIR)/$(pkgdatadir)/Procedures/Get
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -20,7 +20,7 @@
SUBDIRS = Parametrization GDIF . SensorPlugins
@@ -11,8 +40,8 @@ http://bugs.gentoo.org/show_bug.cgi?id=297536
AM_CFLAGS =
bin_PROGRAMS = eugene
---- eugene-3.6/src/MSensor.cc
-+++ eugene-3.6/src/MSensor.cc
+--- a/src/MSensor.cc
++++ b/src/MSensor.cc
@@ -97,7 +97,7 @@
std::string use_name;
@@ -22,22 +51,3 @@ http://bugs.gentoo.org/show_bug.cgi?id=297536
// On récupère les couples nom de sensor/priorité du .par
PAR.ResetIter();
---- eugene-3.6/Makefile.am
-+++ eugene-3.6/Makefile.am
-@@ -125,7 +125,7 @@
- $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Style
- $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Javascripts
- $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Images
-- $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/plugins
-+ $(INSTALL) -d $(DESTDIR)/$(libdir)/eugene/plugins
- $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/cfg
- $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/models
- $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/models/WAM
-@@ -144,6 +144,6 @@
- $(INSTALL) -m 644 $(srcdir)/web/Images/*jpg $(DESTDIR)/$(pkgdatadir)/web/Images
- $(INSTALL) -m 644 $(srcdir)/cfg/*.obo $(DESTDIR)/$(pkgdatadir)/cfg
- $(INSTALL) -m 644 $(srcdir)/cfg/*.par $(DESTDIR)/$(pkgdatadir)/cfg
-- $(INSTALL) src/SensorPlugins/*/*.so $(DESTDIR)/$(pkgdatadir)/plugins
-+ $(INSTALL) src/SensorPlugins/*/*.so $(DESTDIR)/$(libdir)/eugene/plugins
- $(INSTALL) $(srcdir)/Procedures/Eval/egn_* $(DESTDIR)/$(pkgdatadir)/Procedures/Eval
- $(INSTALL) $(srcdir)/Procedures/Get/egn_* $(DESTDIR)/$(pkgdatadir)/Procedures/Get
diff --git a/sci-biology/eugene/files/eugene-4.1d-portable-getopt.patch b/sci-biology/eugene/files/eugene-4.1d-portable-getopt.patch
new file mode 100644
index 000000000000..156cb4bbdfac
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-4.1d-portable-getopt.patch
@@ -0,0 +1,74 @@
+--- a/src/Param.h
++++ b/src/Param.h
+@@ -28,26 +28,14 @@
+ #include <vector>
+ #include <string>
+ #include <string.h>
++#include <unistd.h>
+ #ifdef HAVE_STRINGS_H
+ #include <strings.h>
+ #endif
+-// MacOS-X has getopt() defined is stdlib and the library in the libSystem
+-#ifndef __APPLE__
+-#ifdef HAVE_GETOPT_H
+-#include <getopt.h>
+-#else
+-#ifndef HAVE_GETOPT
+-#include "getopt.h"
+-#endif
+-#endif
+-#endif
+
+ #include "Const.h"
+ #include "System.h"
+
+-extern char *optarg;
+-extern int optind;
+-
+
+ class ltstr
+ {
+--- a/src/SensorPlugins/MarkovIMM/GetData/CEM.cc
++++ b/src/SensorPlugins/MarkovIMM/GetData/CEM.cc
+@@ -22,18 +22,11 @@
+ #include "../../../../config.h"
+ #endif
+
+-#ifdef HAVE_GETOPT_H
+-#include <getopt.h>
+-#else
+-#ifndef HAVE_GETOPT
+-#include "../../../getopt.h"
+-#endif
+-#endif
+-
+ #include "../../../System.cc"
+ #include "../../../Const.h"
+ #include "../../0_SensorTk/EndianConv.h"
+ #include "strarray.h"
++#include "unistd.h"
+ #include <vector>
+
+ // Constantes
+--- a/src/SensorPlugins/MarkovIMM/GetData/TrainIMM.cc
++++ b/src/SensorPlugins/MarkovIMM/GetData/TrainIMM.cc
+@@ -22,18 +22,11 @@
+ #include "../../../../config.h"
+ #endif
+
+-#ifdef HAVE_GETOPT_H
+-#include <getopt.h>
+-#else
+-#ifndef HAVE_GETOPT
+-#include "../../../getopt.h"
+-#endif
+-#endif
+-
+ #include "../../../System.cc"
+ #include "../../../Const.h"
+ #include "../../0_SensorTk/EndianConv.h"
+ #include "strarray.h"
++#include "unistd.h"
+
+
+ // Constantes