summaryrefslogtreecommitdiff
path: root/sci-biology/fasttree/files/CMakeLists.txt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/fasttree/files/CMakeLists.txt
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/fasttree/files/CMakeLists.txt')
-rw-r--r--sci-biology/fasttree/files/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-biology/fasttree/files/CMakeLists.txt b/sci-biology/fasttree/files/CMakeLists.txt
new file mode 100644
index 000000000000..e7c53afdaf36
--- /dev/null
+++ b/sci-biology/fasttree/files/CMakeLists.txt
@@ -0,0 +1,30 @@
+cmake_minimum_required (VERSION 2.6)
+project(fasttree C)
+
+option(USE_OPENMP "Use OpenMP to parallelize many of the steps in computing a tree" ON)
+option(USE_DOUBLE "Use double precission" OFF)
+option(HAS_SSE3 "Use SSE2/SSE3 instructions to speed up some inner loops" ON)
+
+if(USE_OPENMP)
+ SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DOPENMP -fopenmp" )
+ SET( CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -DOPENMP -fopenmp" )
+endif(USE_OPENMP)
+
+if(USE_DOUBLE)
+ SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DUSE_DOUBLE" )
+endif(USE_DOUBLE)
+
+if(NOT HAS_SSE3)
+ SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DNO_SSE" )
+endif(NOT HAS_SSE3)
+
+
+add_executable(FastTree FastTree-${VERSION}.c)
+add_executable(FastTreeUPGMA FastTreeUPGMA-${VERSION}.c)
+
+target_link_libraries(FastTree m)
+target_link_libraries(FastTreeUPGMA m)
+
+install (TARGETS FastTree FastTreeUPGMA DESTINATION bin)
+
+install(FILES MOTree.pm CompareTree.pl CompareToBootstrap.pl DESTINATION share/fasttree)