summaryrefslogtreecommitdiff
path: root/sci-biology/fasttree/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /sci-biology/fasttree/files
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'sci-biology/fasttree/files')
-rw-r--r--sci-biology/fasttree/files/CMakeLists.txt25
-rw-r--r--sci-biology/fasttree/files/fasttree-2.1.11-format-security.patch (renamed from sci-biology/fasttree/files/fasttree-2.1.8-format-security.patch)8
2 files changed, 17 insertions, 16 deletions
diff --git a/sci-biology/fasttree/files/CMakeLists.txt b/sci-biology/fasttree/files/CMakeLists.txt
index e7c53afdaf36..c52b90cc7be2 100644
--- a/sci-biology/fasttree/files/CMakeLists.txt
+++ b/sci-biology/fasttree/files/CMakeLists.txt
@@ -1,23 +1,24 @@
-cmake_minimum_required (VERSION 2.6)
+cmake_minimum_required (VERSION 2.8.12)
project(fasttree C)
+include(GNUInstallDirs)
+
option(USE_OPENMP "Use OpenMP to parallelize many of the steps in computing a tree" ON)
-option(USE_DOUBLE "Use double precission" OFF)
+option(USE_DOUBLE "Use double precision" OFF)
option(HAS_SSE3 "Use SSE2/SSE3 instructions to speed up some inner loops" ON)
if(USE_OPENMP)
- SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DOPENMP -fopenmp" )
- SET( CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -DOPENMP -fopenmp" )
-endif(USE_OPENMP)
+ set( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DOPENMP -fopenmp" )
+ set( CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -DOPENMP -fopenmp" )
+endif()
if(USE_DOUBLE)
- SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DUSE_DOUBLE" )
-endif(USE_DOUBLE)
+ set( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DUSE_DOUBLE" )
+endif()
if(NOT HAS_SSE3)
- SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DNO_SSE" )
-endif(NOT HAS_SSE3)
-
+ set( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DNO_SSE" )
+endif()
add_executable(FastTree FastTree-${VERSION}.c)
add_executable(FastTreeUPGMA FastTreeUPGMA-${VERSION}.c)
@@ -25,6 +26,6 @@ add_executable(FastTreeUPGMA FastTreeUPGMA-${VERSION}.c)
target_link_libraries(FastTree m)
target_link_libraries(FastTreeUPGMA m)
-install (TARGETS FastTree FastTreeUPGMA DESTINATION bin)
+install (TARGETS FastTree FastTreeUPGMA DESTINATION ${CMAKE_INSTALL_BINDIR})
-install(FILES MOTree.pm CompareTree.pl CompareToBootstrap.pl DESTINATION share/fasttree)
+install(FILES MOTree.pm CompareTree.pl CompareToBootstrap.pl DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/fasttree)
diff --git a/sci-biology/fasttree/files/fasttree-2.1.8-format-security.patch b/sci-biology/fasttree/files/fasttree-2.1.11-format-security.patch
index 15f5c174ec40..45023e4215f6 100644
--- a/sci-biology/fasttree/files/fasttree-2.1.8-format-security.patch
+++ b/sci-biology/fasttree/files/fasttree-2.1.11-format-security.patch
@@ -1,10 +1,10 @@
- FastTreeUPGMA-2.1.8.c | 4 ++--
+ FastTreeUPGMA-2.1.11.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
-diff --git a/FastTreeUPGMA-2.1.8.c b/FastTreeUPGMA-2.1.8.c
+diff --git a/FastTreeUPGMA-2.1.11.c b/FastTreeUPGMA-2.1.11.c
index af76cb1..4065f42 100644
---- a/FastTreeUPGMA-2.1.8.c
-+++ b/FastTreeUPGMA-2.1.8.c
+--- a/FastTreeUPGMA-2.1.11.c
++++ b/FastTreeUPGMA-2.1.11.c
@@ -535,7 +535,7 @@ int main(int argc, char **argv) {
break;
}