summaryrefslogtreecommitdiff
path: root/sci-biology/pilercr/pilercr-1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /sci-biology/pilercr/pilercr-1.0-r2.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'sci-biology/pilercr/pilercr-1.0-r2.ebuild')
-rw-r--r--sci-biology/pilercr/pilercr-1.0-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-biology/pilercr/pilercr-1.0-r2.ebuild b/sci-biology/pilercr/pilercr-1.0-r2.ebuild
new file mode 100644
index 000000000000..819fb3fbb03e
--- /dev/null
+++ b/sci-biology/pilercr/pilercr-1.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Analysis of Clustered Regularly Interspaced Short Palindromic Repeats (CRISPRs)"
+HOMEPAGE="http://www.drive5.com/pilercr/"
+SRC_URI="http://www.drive5.com/pilercr/pilercr1.06.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-fix-build-system.patch
+ "${FILESDIR}"/${PN}-1.0-gcc43.patch
+)
+
+src_configure() {
+ tc-export CXX
+}
+
+src_install() {
+ dobin pilercr
+}