summaryrefslogtreecommitdiff
path: root/sci-biology/rmblast/rmblast-1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/rmblast/rmblast-1.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/rmblast/rmblast-1.2-r1.ebuild')
-rw-r--r--sci-biology/rmblast/rmblast-1.2-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-biology/rmblast/rmblast-1.2-r1.ebuild b/sci-biology/rmblast/rmblast-1.2-r1.ebuild
new file mode 100644
index 000000000000..db7c5a246910
--- /dev/null
+++ b/sci-biology/rmblast/rmblast-1.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_NCBI_BLAST_V=2.2.23+
+
+DESCRIPTION="RepeatMasker compatible version of NCBI BLAST+"
+HOMEPAGE="http://www.repeatmasker.org/RMBlast.html"
+SRC_URI="http://www.repeatmasker.org/rmblast-${PV}-ncbi-blast-${MY_NCBI_BLAST_V}-src.tar.gz"
+
+LICENSE="OSL-2.1"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/boost"
+DEPEND="${RDEPEND}
+ app-arch/cpio"
+
+S="${WORKDIR}/${P}-ncbi-blast-${MY_NCBI_BLAST_V}-src/c++"
+
+src_prepare() {
+ filter-ldflags -Wl,--as-needed
+ sed \
+ -e 's/-print-file-name=libstdc++.a//' \
+ -e '/sed/ s/\([gO]\[0-9\]\)\*/\1\\+/' \
+ -e "/DEF_FAST_FLAGS=/s:=\".*\":=\"${CFLAGS}\":g" \
+ -e 's/2.95\* | 2.96\* | 3\.\* | 4\.\* )/2.95\* | 2.96\* | \[3-9\]\.\* )/g' \
+ -i src/build-system/configure || die
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_configure() {
+ tc-export CXX CC
+
+ "${S}"/configure --without-debug \
+ --with-mt \
+ --without-static \
+ --with-dll \
+ --prefix="${ED}"/opt/${PN} \
+ --with-boost="${EPREFIX}/usr/include/boost" \
+ || die
+}