summaryrefslogtreecommitdiff
path: root/sci-biology/sibsim4/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-biology/sibsim4/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-biology/sibsim4/files')
-rw-r--r--sci-biology/sibsim4/files/sibsim4-0.20-makefile.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-biology/sibsim4/files/sibsim4-0.20-makefile.patch b/sci-biology/sibsim4/files/sibsim4-0.20-makefile.patch
new file mode 100644
index 000000000000..6436747e3dd9
--- /dev/null
+++ b/sci-biology/sibsim4/files/sibsim4-0.20-makefile.patch
@@ -0,0 +1,26 @@
+--- a/Makefile
++++ b/Makefile
+@@ -21,13 +21,12 @@
+ # to change it to this:
+ # CFLAGS = -Xc
+
+-CFLAGS = -std=gnu99 -W -Wall -Wconversion -pedantic $(DEBUG) $(OPT)
++CFLAGS += -std=gnu99 -Wall -Wconversion -pedantic
+
+
+ # The default is GCC. On Solaris, you might put:
+ # CC = /opt/SUNWspro/bin/cc
+
+-CC = gcc
+
+
+ # Depending on the compile flags you use, you might need to explicitly use the
+@@ -42,7 +41,7 @@
+ OBJS = sim4b1.o align.o misc.o sim4.init.o
+
+ sim4: $(OBJS)
+- $(CC) -o SIBsim4 $(CFLAGS) $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o SIBsim4 $(OBJS) $(LIBS)
+
+ clean:
+ rm -f SIBsim4 *.o